POJ 1753 BFS

Flip Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 44450 Accepted: 19085

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source

题意:
4*4的黑白棋盘,给出初始状态,翻转一个棋子他周围的4个棋子也翻转,问把所有棋子变成同一种颜色的最少反转次数。
代码:
//求最少反转次数可以bfs,因为只有4*4所以可以把每行的状态压缩一下用四维数组来标记是否出现过此状态。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int mp[6][6],vis[1<<4][1<<4][1<<4][1<<4];
struct Node{
    int mp[6][6],tim;
}no1,no2;
void Make(Node a){
    int sta[4]={0};
    for(int i=0;i<4;i++){
        for(int j=0;j<4;j++)
            sta[i]|=(a.mp[i][j]<<(3-j));
    }
    vis[sta[0]][sta[1]][sta[2]][sta[3]]=1;
}
bool Chack(Node a){
    for(int i=0;i<4;i++)
        for(int j=0;j<4;j++)
            if(a.mp[i][j]!=a.mp[0][0]) return false;
    return true;
}
bool Vis(Node a){
    int sta[4]={0};
    for(int i=0;i<4;i++){
        for(int j=0;j<4;j++)
            sta[i]|=(a.mp[i][j]<<(3-j));
    }
    if(vis[sta[0]][sta[1]][sta[2]][sta[3]]) return 1;
    return 0;
}
Node Change(int x,int y,Node a){
    for(int i=0;i<4;i++){
        for(int j=0;j<4;j++){
            if(i==x&&j==y){
                a.mp[i][j]=!a.mp[i][j];
                if(i+1<=3) a.mp[i+1][j]=!a.mp[i+1][j];
                if(i-1>=0) a.mp[i-1][j]=!a.mp[i-1][j];
                if(j+1<=3) a.mp[i][j+1]=!a.mp[i][j+1];
                if(j-1>=0) a.mp[i][j-1]=!a.mp[i][j-1];
                a.tim++;return a;
            }
        }
    }
}
int Bfs(){
    memset(vis,0,sizeof(vis));
    queue<Node>q;
    no1.tim=0;
    q.push(no1);
    Make(no1);
    while(!q.empty()){
        no1=q.front();q.pop();
        if(Chack(no1)) return no1.tim;
        for(int i=0;i<4;i++){
            for(int j=0;j<4;j++){
                no2=Change(i,j,no1);
                if(Vis(no2)) continue;
                Make(no2);
                q.push(no2);
            }
        }
    }
    return -1;
}
int main()
{
    char s[6];
    for(int i=0;i<4;i++){
        scanf("%s",s);
        for(int j=0;j<4;j++)
            no1.mp[i][j]=(s[j]=='b'?1:0);
    }
    int ans=Bfs();
    if(ans==-1) printf("Impossible\n");
    else printf("%d\n",ans);
    return 0;
}

 

转载于:https://www.cnblogs.com/--ZHIYUAN/p/6740991.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值