qxt: 并不支持qt5,其他excel解析的情况

在qt官网中推荐使用qxt解析csv文件

qxt在linux下并不支持qt5,主要原因是qt5使用了一些渲染和处理,这些都将qxt的原生性降低了。qxt的一部分仍然可以被复用,但目前并无复用的案例。


Excel解析,在windows下,qt提供了qtaxobject,但在Linux下是不可用的。这是因为qt只提供了针对window axobject 的接口驱动.

由于Linux并不支持excel解析(openoffice肯定支持,但openoffice使用了原生的soffice的渲染引擎,他们说要把改引擎架到qt上,但还未见效果),所以qt不支持linux的excel解析,这可以暂时被接受。

阅读更多
个人分类: qt5
想对作者说点什么? 我来说一句

qt5QjsonDemo

2014年04月22日 3KB 下载

QT5解析json文件demo

2016年05月08日 5.45MB 下载

没有更多推荐了,返回首页

不良信息举报

qxt: 并不支持qt5,其他excel解析的情况

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭