NYOJ30 Gone Fishing 贪心+枚举

原题链接

之前WA了两次,都是由于没考虑到0的情况。

样例输入
2 湖的个数
1 小时数
10 1 最初5分钟捕鱼数
2 5 每5分钟减少的鱼数
2 跑路间隔时间*5 min




10 15 20 17 
0 3 4 3 
1 2 3 




10 15 50 30 
0 3 4 3 
1 2 3 



样例输出
45, 5 
Number of fish expected: 31

 
240, 0, 0, 0 

Number of fish expected: 480 


115, 10, 50, 35 

Number of fish expected: 724

//关键点:求出在第一个湖耗时最长的,所以如果有多余的时间则尽量都耗在第一个湖边
//贪心+枚举
#include <stdio.h>
#include <string.h>
int initialLakeFishes[26], fishReduce[26], moveTime[26];
int timeSpend[26], eachFish[26], totalFish[26], copyInitialLake[26];

struct Node{
	int lake, fish;
} maxLake;

int findMaxLake(int n){
	maxLake.lake = maxLake.fish = 0;
	int i;
	for(i = 0; i <= n; ++i){
		if(copyInitialLake[i] > maxLake.fish)
			maxLake.fish = copyInitialLake[i], maxLake.lake = i;		
	}
	return maxLake.fish;
}

void mergeSum(int n){
	int sum = 0;
	for(int i = 0; i <= n; ++i)
		sum += eachFish[i];
	totalFish[n] = sum;
}

int findMaxTotal(int n){
	int i, max = 0, j = 0;
	for(i = 0; i <= n; ++i)
		if(totalFish[i] > max)
			max = totalFish[i], j = i;
	return j;
}

int main(){
	int lakeNumbers, hours;
	int hoursToMinutes, copy_hoursToMinutes, i, n;
	while(scanf("%d", &lakeNumbers), lakeNumbers){
		scanf("%d", &hours);
		hoursToMinutes = hours * 60;
		copy_hoursToMinutes = hoursToMinutes;
		for(i = 0; i != lakeNumbers; ++i)
			scanf("%d", &initialLakeFishes[i]);
		for(i = 0; i != lakeNumbers; ++i)
			scanf("%d", &fishReduce[i]);
		for(i = 0; i != lakeNumbers - 1; ++i)
			scanf("%d", &moveTime[i]);
		//从第一个湖开始枚举,假设小明最远到达第n个湖
		//则小明可以在这n个湖之间“瞬移”。		
		for(n = 0; n != lakeNumbers; ++n){
			memcpy(copyInitialLake, initialLakeFishes, sizeof(initialLakeFishes));
			for(i = 0; i < n; ++i){
				hoursToMinutes -= moveTime[i] * 5;
			}
			while(hoursToMinutes >= 5){
				if(findMaxLake(n) == 0)
					break;
				timeSpend[maxLake.lake] += 5;
				hoursToMinutes -= 5;
				eachFish[maxLake.lake] += maxLake.fish;
				copyInitialLake[maxLake.lake] -= fishReduce[maxLake.lake];
			}
			mergeSum(n);
			memset(eachFish, 0, sizeof(eachFish));
			memset(timeSpend, 0, sizeof(timeSpend));
			hoursToMinutes = copy_hoursToMinutes;
		}
		
		memcpy(copyInitialLake, initialLakeFishes, sizeof(initialLakeFishes));
		n = findMaxTotal(lakeNumbers - 1);
		for(i = 0; i < n; ++i){
			hoursToMinutes -= moveTime[i] * 5;
		}
		
		while(hoursToMinutes >= 5){
			if(findMaxLake(n) == 0)
				break;
			timeSpend[maxLake.lake] += 5;
			hoursToMinutes -= 5;
			eachFish[maxLake.lake] += maxLake.fish;
			copyInitialLake[maxLake.lake] -= fishReduce[maxLake.lake];
		}
		while(hoursToMinutes >= 5){
			timeSpend[0] += 5;
			hoursToMinutes -= 5;
		}
			
		printf("%d", timeSpend[0]);
		for(i = 1; i != lakeNumbers; ++i)
			printf(", %d", timeSpend[i]);		
		printf("\nNumber of fish expected: %d\n\n", totalFish[n]); 
		memset(totalFish, 0, sizeof(totalFish));
		memset(eachFish, 0, sizeof(eachFish));
		memset(timeSpend, 0, sizeof(timeSpend));
	}
	return 0;
}





转载于:https://www.cnblogs.com/changmu/p/3639708.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
x1y2 x2y3 x3y1-x1y3-x2y1-x3y2 是计算三角形面积的公式中的一部分。 在这个公式中,x1、x2、x3分别表示三角形的三个顶点的x坐标,y1、y2、y3分别表示三角形的三个顶点的y坐标。通过计算这个表达式的值,可以得到三角形的面积。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [TetraCluster:使用并行Java 2库的Java并行程序。 该程序在群集并行计算机上运行,​​以从给定的点集中找到...](https://download.csdn.net/download/weixin_42171208/18283141)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] - *2* [线性代数有个题,求正交变换x=Qy,化二次型f(x1,x2,x3)=8x1x2+8x1x3+8x2x3为标准型求出特征值](https://blog.csdn.net/weixin_39956182/article/details/115882118)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] - *3* [nyoj-67-三角形面积(S=(1/2)*(x1y2+x2y3+x3y1-x1y3-x2y1-x3y2))](https://blog.csdn.net/weixin_30492601/article/details/99541033)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值