Test for Job 图上的动态规划(DAG)

Test for Job
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 11399 Accepted: 2697

Description

Mr.Dog was fired by his company. In order to support his family, he must find a new job as soon as possible. Nowadays, It's hard to have a job, since there are swelling numbers of the unemployed. So some companies often use hard tests for their recruitment.

The test is like this: starting from a source-city, you may pass through some directed roads to reach another city. Each time you reach a city, you can earn some profit or pay some fee, Let this process continue until you reach a target-city. The boss will compute the expense you spent for your trip and the profit you have just obtained. Finally, he will decide whether you can be hired.

In order to get the job, Mr.Dog managed to obtain the knowledge of the net profit Vi of all cities he may reach (a negative Vi indicates that money is spent rather than gained) and the connection between cities. A city with no roads leading to it is a source-city and a city with no roads leading to other cities is a target-city. The mission of Mr.Dog is to start from a source-city and choose a route leading to a target-city through which he can get the maximum profit.

Input

The input file includes several test cases. 
The first line of each test case contains 2 integers  n and  m(1 ≤  n ≤ 100000, 0 ≤  m ≤ 1000000) indicating the number of cities and roads. 
The next  n lines each contain a single integer. The  ith line describes the net profit of the city  iVi (0 ≤ | Vi| ≤ 20000) 
The next m lines each contain two integers  xy indicating that there is a road leads from city  x to city  y. It is guaranteed that each road appears exactly once, and there is no way to return to a previous city. 

Output

The output file contains one line for each test cases, in which contains an integer indicating the maximum profit Dog is able to obtain (or the minimum expenditure to spend)

Sample Input

6 5
1
2
2
3
3
4
1 2
1 3
2 4
3 4
5 6

Sample Output

7

Hint

Source

POJ Monthly--2007.07.08, 落叶飞雪
 
按照拓扑序列进行DP
#include <iostream>
#include <string>
#include <cstdio>
#include <vector>
#include <algorithm>
#include <deque>
#include <map>
#include <stack>
#include <cstring>
using namespace std;
typedef long long LL;
#define INF 0x3f3f3f3f
#define MAXN 200000+9
#define MAXM 2000000 + 9


struct edge
{
    LL next, v, cost;
}E[MAXM];
LL n, m;
LL head[MAXN], tot;
LL cnt[MAXN], topsort[MAXN];
LL val[MAXN], dist[MAXN],out[MAXN];
void init()
{
    tot = 0;
    memset(head, -1, sizeof(head));
    memset(cnt, 0, sizeof(cnt));
    memset(out, 0, sizeof(out));
}
void addedge(LL f, LL t, LL d)
{
    E[tot].v = t;
    E[tot].cost = d;
    E[tot].next = head[f];
    head[f] = tot++;
}
LL Topsort()
{
    LL p = 0;
    for (LL i = 1; i <= n; i++)
    {
        if (cnt[i] == 0)
            dist[i] = val[i], topsort[p++] = i, cnt[i]--;
        else
            dist[i] = -INF;
    }
    for (LL i = 0; i < p; i++)
    {
        for (LL j = head[topsort[i]]; j != -1; j = E[j].next)
        {
            LL v = E[j].v;
            dist[v] = max(dist[v], dist[topsort[i]] + E[j].cost);
            if (--cnt[v] == 0)
                topsort[p++] = v;
        }
    }
    LL ans = -INF;
    for (int i = 1; i <= n; i++)
        if (!out[i])
            ans = max(ans, dist[i]);
    return ans;

}

int main()
{
    while (scanf("%lld%lld", &n, &m) != EOF)
    {
        init();
        for (int i = 1; i <= n; i++)
            scanf("%lld", &val[i]);
        LL f, t;
        for (int i = 1; i <= m; i++)
        {
            scanf("%lld%lld", &f, &t);
            addedge(f, t, val[t]);
            cnt[t]++;
            out[f]++;
        }
        printf("%lld\n", Topsort());
    }
}

 

转载于:https://www.cnblogs.com/joeylee97/p/7614667.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值