hdu3501Calculation 2——欧拉函数模板

题目:
Problem Description
Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
 
Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
 
Output
For each test case, you should print the sum module 1000000007 in a line.
 
Sample Input
3 4 0
 
Sample Output
0 2
欧拉函数模板:
先求出φn;
由gcd(n,i)=1得gcd(n,n-i)=1,则与n互素的数之和=φ(n)*n/2;
则ans=小于n的数之和-φ(n)*n/2(注意这里不能为“-φ(n)/2*n”或“-n/2*φ(n)”,先/2可能变成0)。
以下为代码:
#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
long long n,res,ans;
int main()
{
	while(1)
	{
		scanf("%lld",&n);
		if(!n)return 0;
		res=n;
		int nn=n;
		for(int i=2;i*i<=nn;i++)
		{
			if(nn%i==0)
			{
				res-=res/i;//减去其中素因子i的倍数的个数 
//				res=res/i*(i-1);
				while(nn%i==0)nn/=i;//提走素因子i 
			}
		}
		if(nn>1)res-=res/nn;//不能是res--! 
//		if(nn>1)res=res/n*(n-1);
		ans=(n*(n-1)/2-n*res/2)%1000000007;
		printf("%lld\n",ans);
	}
	return 0;
}

  

转载于:https://www.cnblogs.com/Zinn/p/8196820.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值