【BZOJ4099】Trapped in the Haybales Gold STL

【BZOJ4099】Trapped in the Haybales Gold

Description

Farmer John has received a shipment of N large hay bales (1≤N≤100,000), and placed them at various locations along the road leading to his barn. Unfortunately, he completely forgets that Bessie the cow is out grazing along the road, and she may now be trapped within the bales!
Each bale j has a size Sj and a position Pj giving its location along the one-dimensional road. Bessie the cow can move around freely along the road, even up to the position at which a bale is located, but she cannot cross through this position. As an exception, if she runs in the same direction for D units of distance, she builds up enough speed to break through and permanently eliminate any hay bale of size strictly less than D. Of course, after doing this, she might open up more space to allow her to make a run at other hay bales, eliminating them as well.
Bessie can escape to freedom if she can eventually break through either the leftmost or rightmost hay bale. Please compute the total area of the road consisting of real-valued starting positions from which Bessie cannot escape.
农民约翰收到了N个干草包(1≤N≤100000),并将它们放置在一条道路上的
不同位置。不幸的是,他忘记了贝西是沿着道路放牧,她现在可能被困在干
草包里了! 
每个包有一个大小Sj和位置Pj。贝西可以沿着道路自由走动,甚至可以
到达一捆草包所在的位置,但她必须通过这个位置。如果她向同一方向跑D单
位的距离,她就可以突破大小严格小于D的干草包。当然,这样做后她就可以
开发出更广阔的空间,突破其他干草包。 
如果贝西可以突破最左边或最右边的干草包,她就可以重获新生。请计
算贝西无法逃脱的道路的面积。 

Input

The first line of input contains N. Each of the next N lines describes a bale, and contains two integers giving its size and position, each in the range 1…10^9. All positions are distinct.
输入的第一行包含一个整数N。以下N行每行描述一捆干草包,包含两个
整数,分别表示它的大小和位置,每个数的范围是1...10^9。所有的位置是不同
的。 

Output

Print a single integer, giving the area of the road from which Bessie cannot escape.
 
输出一个整数,表示贝西无法逃脱的道路面积。 

Sample Input

5
8 1
1 4
8 8
7 15
4 20

Sample Output

14

题解:这种思路题果然难搞,无奈上官网看的题解。

如果我们将干草堆按坐标排序,对于某段区间[i,j],加入Bessie能突破[i+1,j-1]内的所有干草,但是就是突破不了[i,j],那就说明[i,j]里面一定没有比i,j更大的干草堆

因此,我们将干草堆按大小从大到小排序,一个一个加到坐标轴上,每加入一个干草堆,就找到它的前驱和后继,并分别判断这两段区间能否突破,如果不能,将区间标记一下就好了(我比较懒用的差分数组来打标记)

前驱后继可以用set来维护,但注意查询到前驱后继时我们还需要知道前驱后继的干草堆大小,这个记录一下排在第i位(按坐标排序)的干草堆编号就行了

#include <cstdio>
#include <iostream>
#include <set>
#include <algorithm>
using namespace std;
const int maxn=100010;
int h[maxn],x[maxn],rx[maxn],rh[maxn];
bool cmp1(int a,int b)
{
	return x[a]<x[b];
}
bool cmp2(int a,int b)
{
	return h[a]>h[b];
}
int s[maxn],sum;
int n,ref[maxn],ans;
set <int> ms;
int main()
{
	scanf("%d",&n);
	int i,j;
	for(i=1;i<=n;i++)	scanf("%d%d",&h[i],&x[i]),rx[i]=rh[i]=i;
		//rx,rh存储的其实是编号,我们是在将编号排序 
	sort(rx+1,rx+n+1,cmp1);
	for(i=1;i<=n;i++)
	{
		ref[i]=x[rx[i]];
		x[rx[i]]=i;
	}
	sort(rh+1,rh+n+1,cmp2);
	set<int>::iterator it;
	for(i=1;i<=n;i++)
	{
		it=ms.lower_bound(x[rh[i]]);
		if(it!=ms.begin()&&!ms.empty())
		{
			it--;
			j=rx[*it];
			if(ref[x[rh[i]]]-ref[x[j]]<=min(h[rh[i]],h[j]))
			{
				s[x[j]]++;
				s[x[rh[i]]]--;
			}
		}
		it=ms.upper_bound(x[rh[i]]);
		if(it!=ms.end())
		{
			j=rx[*it];
			if(ref[x[j]]-ref[x[rh[i]]]<=min(h[rh[i]],h[j]))
			{
				s[x[rh[i]]]++;
				s[x[j]]--;
			}
		}
		ms.insert(x[rh[i]]);
	}
	for(i=1;i<=n;i++)
	{
		ans+=(sum>0)*(ref[i]-ref[i-1]);
		sum+=s[i];
	}
	printf("%d",ans);
	return 0;
}

转载于:https://www.cnblogs.com/CQzhangyu/p/6430362.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
BZOJ 2908 题目是一个数据下载任务。这个任务要求下载指定的数据文件,并统计文件中小于等于给定整数的数字个数。 为了完成这个任务,首先需要选择一个合适的网址来下载文件。我们可以使用一个网络爬虫库,如Python中的Requests库,来帮助我们完成文件下载的操作。 首先,我们需要使用Requests库中的get()方法来访问目标网址,并将目标文件下载到我们的本地计算机中。可以使用以下代码实现文件下载: ```python import requests url = '目标文件的网址' response = requests.get(url) with open('本地保存文件的路径', 'wb') as file: file.write(response.content) ``` 下载完成后,我们可以使用Python内置的open()函数打开已下载的文件,并按行读取文件内容。可以使用以下代码实现文件内容读取: ```python count = 0 with open('本地保存文件的路径', 'r') as file: for line in file: # 在这里实现对每一行数据的判断 # 如果小于等于给定整数,count 加 1 # 否则,不进行任何操作 ``` 在每一行的处理过程中,我们可以使用split()方法将一行数据分割成多个字符串,并使用int()函数将其转换为整数。然后,我们可以将该整数与给定整数进行比较,以判断是否小于等于给定整数。 最后,我们可以将统计结果打印出来,以满足题目的要求。 综上所述,以上是关于解决 BZOJ 2908 数据下载任务的简要步骤和代码实现。 希望对您有所帮助。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值