POJ3624 Charm Bracelet 【01背包】

Charm Bracelet
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 22621 Accepted: 10157

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weightWi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

题意:给定物品数量n和背包容量m,n个物品的重量weight和价值val,求能获得的最大价值。

题解:状态转移方程:dp[i][j] = max(dp[i-1][j], dp[i-1][j-w[i]] + v[i]);当中状态dp[i][j]表示前i个物品放在容量为j的背包中能获得的最大价值。

二维数组能够压缩成一维以节省空间,可是内层循环须要倒序。

原始版本号:耗时360ms

#include <stdio.h>
#define maxn 12882

int dp[maxn];

int max(int a, int b){ return a > b ? a : b; }

int main()
{
    int n, totalWeight, i, j, weight, val;
    scanf("%d%d", &n, &totalWeight);
    for(i = 1; i <= n; ++i){
        scanf("%d%d", &weight, &val);
        for(j = totalWeight; j; --j){
            if(j >= weight) dp[j] = max(dp[j], dp[j - weight] + val);
        }
    }
    printf("%d\n", dp[totalWeight]);
    return 0;
}<span style="font-family:FangSong_GB2312;">
</span>

优化后的代码:耗时219ms

#include <stdio.h>
#define maxn 12882

int dp[maxn];

int main()
{
    int n, totalWeight, i, j, weight, val;
    scanf("%d%d", &n, &totalWeight);
    for(i = 1; i <= n; ++i){
        scanf("%d%d", &weight, &val);
        for(j = totalWeight; j; --j){
            if(j >= weight && dp[j - weight] + val > dp[j]) 
				dp[j] = dp[j - weight] + val;
        }
    }
    printf("%d\n", dp[totalWeight]);
    return 0;
}

用二维dp数组写了一个,果断的超了内存,占用内存大概12882*3404*4/1024=171兆。题目限制是65兆

TLE:

#include <stdio.h>
#define maxn 12882

int dp[3404][maxn];

int max(int a, int b){ return a > b ? a : b; }

int main()
{
    int n, m, weight, val, i, j;
    scanf("%d%d", &n, &m);
    for(i = 1; i <= n; ++i){
        scanf("%d%d", &weight, &val);
        for(j = 1; j <= m; ++j)
            if(j >= weight)
                dp[i][j] = max(dp[i-1][j], dp[i-1][j-weight] + val);
            else dp[i][j] = dp[i-1][j];
    }
    printf("%d\n", dp[n][m]);
    return 0;
}



转载于:https://www.cnblogs.com/zhchoutai/p/8452787.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值