HDU 1885 Key Task 国家压缩+搜索

Key Task

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1176    Accepted Submission(s): 462


Problem Description
The Czech Technical University is rather old — you already know that it celebrates 300 years of its existence in 2007. Some of the university buildings are old as well. And the navigation in old buildings can sometimes be a little bit tricky, because of strange long corridors that fork and join at absolutely unexpected places. 

The result is that some first-graders have often di?culties finding the right way to their classes. Therefore, the Student Union has developed a computer game to help the students to practice their orientation skills. The goal of the game is to find the way out of a labyrinth. Your task is to write a verification software that solves this game. 

The labyrinth is a 2-dimensional grid of squares, each square is either free or filled with a wall. Some of the free squares may contain doors or keys. There are four di?erent types of keys and doors: blue, yellow, red, and green. Each key can open only doors of the same color. 

You can move between adjacent free squares vertically or horizontally, diagonal movement is not allowed. You may not go across walls and you cannot leave the labyrinth area. If a square contains a door, you may go there only if you have stepped on a square with an appropriate key before.
 

Input
The input consists of several maps. Each map begins with a line containing two integer numbers R and C (1 ≤ R, C ≤ 100) specifying the map size. Then there are R lines each containing C characters. Each character is one of the following: 



Note that it is allowed to have 
more than one exit,
no exit at all,
more doors and/or keys of the same color, and
keys without corresponding doors and vice versa.

You may assume that the marker of your position (“*”) will appear exactly once in every map. 

There is one blank line after each map. The input is terminated by two zeros in place of the map size.
 

Output
For each map, print one line containing the sentence “Escape possible in S steps.”, where S is the smallest possible number of step to reach any of the exits. If no exit can be reached, output the string “The poor student is trapped!” instead. 

One step is defined as a movement between two adjacent cells. Grabbing a key or unlocking a door does not count as a step.
 

Sample Input
 
    
1 10 *........X 1 3 *#X 3 20 #################### #XY.gBr.*.Rb.G.GG.y# #################### 0 0
 

Sample Output
 
    
Escape possible in 9 steps. The poor student is trapped! Escape possible in 45 steps.
 

每一个位置有16种状态,能够用一个vis三维数组表示每一个点的16种状态,对于四种锁,每种锁用一位来表示,有钥匙标记为1。否则标记为0.然后bfs搜索一下即可了。
//109MS	556K
#include<stdio.h>
#include<queue>
#include<string.h>
#include<algorithm>
#define M 107
using namespace std;
int n,m,s,t;
int dir[4][2]={{-1,0},{1,0},{0,1},{0,-1}};
char g[M][M];
bool vis[M][M][17];
char up[4]={'B','Y','R','G'};
char low[4]={'b','y','r','g'};
struct node
{
    int step,x,y,key;
};
int bfs()
{
    queue<node>q;
    node now,next;
    now.x=s;now.y=t;now.step=now.key=0;
    vis[s][t][0]=true;
    q.push(now);
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        if(g[now.x][now.y]=='X')return now.step;
        for(int i=0;i<4;i++)
        {
            next.x=now.x+dir[i][0];
            next.y=now.y+dir[i][1];
            next.step=now.step+1;
            next.key=now.key;
            if(next.x<1||next.x>n||next.y<1||next.y>m||g[next.x][next.y]=='#')continue;//假设越界
            if(g[next.x][next.y]>='A'&&g[next.x][next.y]<='Z'&&g[next.x][next.y]!='X')
            {
                for(int j=0;j<4;j++)
                    if(g[next.x][next.y]==up[j])
                    {
                        if(next.key&(1<<j)&&!vis[next.x][next.y][next.key])//假设没有訪问过且拥有此锁的钥匙
                        {
                            vis[next.x][next.y][next.key]=true;
                            q.push(next);
                        }
                        break;
                    }
            }
            else if(g[next.x][next.y]>='a'&&g[next.x][next.y]<='z')
            {
                for(int j=0;j<4;j++)
                    if(g[next.x][next.y]==low[j])
                    {
                        if((next.key&(1<<j))==0)//假设没有此钥匙
                            next.key+=(1<<j);
                        if(!vis[next.x][next.y][next.key])
                        {
                            vis[next.x][next.y][next.key]=true;
                            q.push(next);
                        }
                    }
            }
            else
            {
                if(!vis[next.x][next.y][next.key])
                {
                    vis[next.x][next.y][next.key]=true;
                    q.push(next);
                }
            }
        }
    }
    return -1;
}
int main()
{
    while(scanf("%d%d",&n,&m),n|m)
    {
        memset(vis,false,sizeof(vis));
        for(int i=1;i<=n;i++)
        {
            scanf("%s",g[i]+1);
            for(int j=1;j<=m;j++)
                if(g[i][j]=='*'){s=i;t=j;}
        }
        int ans=bfs();
        if(ans==-1)printf("The poor student is trapped!\n");
        else printf("Escape possible in %d steps.\n",ans);
    }
    return 0;
}


版权声明:本文博主原创文章。博客,未经同意不得转载。

转载于:https://www.cnblogs.com/lcchuguo/p/4877854.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值