Flag

题目描述

On the Day of the Flag of Russia a shop-owner decided to decorate the show-window of his shop with textile stripes of white, blue and red colors. He wants to satisfy the following conditions:

1.   Stripes of the same color cannot be placed next to each other.

2.   A blue stripe must always be placed between a white and a red or between a red and a white one.

Determine the number of the ways to fulfill his wish.

Example. For N = 3 result is following:

输入

N, the number of the stripes, 1 ≤ N ≤ 45.

输出

M, the number of the ways to decorate the shop-window.

示例输入

3

示例输出

4
#include<stdio.h>   
int main()   
{   
    int n;   
    long long a[46];   
        a[1] = 2;   
        a[2] = 2;   
        a[3] = 4;   
    while(~scanf("%d",&n))   
    {   
        for(int i = 4;i <= n;i++)   
            a[i] = a[i-1]+a[i-2];   
        printf("%lld\n",a[n]);   
    }   
    return 0;   
}   

 

转载于:https://www.cnblogs.com/chiyujie/archive/2013/05/18/3085223.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值