Windows Python3.6环境下安装PyTorch0.4.0

pip安装

  • CPU版本
pip install http://download.pytorch.org/whl/cpu/torch-0.4.0-cp36-cp36m-win_amd64.whl  
  • GPU版本
    目前gpu版本支持cuda8.0,cuda9.0,cuda9.1,请选择版本进行下载安装(不要同时执行下面三条命令)。
    pip install http://download.pytorch.org/whl/cu80/torch-0.4.0-cp36-cp36m-win_amd64.whl    
    pip install http://download.pytorch.org/whl/cu90/torch-0.4.0-cp36-cp36m-win_amd64.whl   
    pip install http://download.pytorch.org/whl/cu91/torch-0.4.0-cp36-cp36m-win_amd64.whl   

Conda安装

执行命令,默认安装的是cuda8.0

conda install pytorch -c pytorch   

如果你需要安装cuda9.0或者cuda9.1的版本,可以执行:

conda install pytorch cuda90 -c pytorch   

conda install pytorch cuda91 -c pytorch   

测试是否安装成功

    import torch  
    print(torch.__version__)  

输出==>0.4.0,即安装成功!

©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页