Parity check

Parity check

Time Limit: 2000MS Memory Limit: 524288KB
Problem Description

Fascinated with the computer games, Gabriel even forgets to study. Now she needs to finish her homework, and there is an easy problem:

f(n)=

She is required to calculate f(n) mod 2 for each given n. Can you help her?

Input

Multiple test cases. Each test case is an integer n(0≤n) in a single line.

Output

For each test case, output the answer of f(n)mod2.

Example Input
2
Example Output
1
Hint
Author
“浪潮杯”山东省第八届ACM大学生程序设计竞赛(感谢青岛科技大学) 

n=0 1 2 3 4 5 6 7 8 9 10 11 12 121     1221
f(n) 0 1 1 2 3 5 13 21 34 55 89 144
输出结果 0 1 1 0 1 1 0 1 1 0 1 1 0 1 0


即以0,1,1三位数一次循环
import java.util.*;
import java.math.*;
public class Main {
	static String str;
	static char [] st = new char [10000];  
	public static void main(String[] args) {
		// TODO Auto-generated method stub
			Scanner in = new Scanner (System.in);
			while(in.hasNext())
			{
			    str=in.next();
			    st=str.toCharArray();
			    int num=0;
			    for(int i=0;i<str.length();i++)
			    {
			    	num=(num*10+(st[i]-'0'))%3;
			    }
			    if(num==0)
			    {
			    	System.out.println(0);
			    }
			    else
			    {
			    	System.out.println(1);
			    }
			}
		
		}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值