zoj3819Average Score

Average Score

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Bob is a freshman in Marjar University. He is clever and diligent. However, he is not good at math, especially in Mathematical Analysis.

After a mid-term exam, Bob was anxious about his grade. He went to the professor asking about the result of the exam. The professor said:

"Too bad! You made me so disappointed."

"Hummm... I am giving lessons to two classes. If you were in the other class, the average scores of both classes will increase."

Now, you are given the scores of all students in the two classes, except for the Bob's. Please calculate the possible range of Bob's score. All scores shall be integers within [0, 100].

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (2 <= N <= 50) and M (1 <= M <= 50) indicating the number of students in Bob's class and the number of students in the other class respectively.

The next line contains N - 1 integers A1A2, .., AN-1 representing the scores of other students in Bob's class.

The last line contains M integers B1B2, .., BM representing the scores of students in the other class.

Output

For each test case, output two integers representing the minimal possible score and the maximal possible score of Bob.

It is guaranteed that the solution always exists.

Sample Input
2
4 3
5 5 5
4 4 3
6 5
5 5 4 5 3
1 3 2 2 1
Sample Output
4 4
2 4
题意:有两个班的同学,其中bob在第一班,然后输入每个班同学的成绩,如果bob属于二班的时候,两个班的平均分都会提高,求bob得分的上下限
分析:bob成绩大于二班平均分,小于一班其他的平均分。我用double存总分,在求最后结果时纠结了好久,上限<平均分,如果平均分是整数的话就是-1,不是整数直接强制转换,下限>平均分,不管平均分怎样都直接+1;
其实后来又搜了一下别人写的,发现直接用int就ok,而且还方便,便于求那个平均分是不是整数,直接取模
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int main()
{
    int t;
    scanf("%d", &t);
    for(int k = 1; k <= t; k++)
    {
        int n,m,score;
        double scoren = 0,scorem = 0;
        scanf("%d%d", &n, &m);
        for(int i = 1; i <= n - 1; i++)
        {
            scanf("%d", &score);
            scoren += score;
        }
        for(int i = 1; i <= m; i++)
        {
            scanf("%d", &score);
            scorem += score;
        }
        printf("%d ",(int) ( scorem / m + 1) );
        if(scoren / (n - 1) == (int) scoren / (n - 1))  //这里一直不确定是不是可行,
        printf("%d\n",(int) ( scoren / (n -1) - 1));
        else
            printf("%d\n", (int) (scoren / (n - 1) ));
    }

    return 0;
}

 

转载于:https://www.cnblogs.com/zhaopAC/p/5071705.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值