7-40 Have Fun with Numbers(30 分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798
我的代码:

#include<stdio.h>
void sort(int a[],int n)
{
    int i,j;
    for(i=1;i<n;i++)
    {
        int temp=a[i];
        for(j=i;j>0&&a[j-1]>temp;--j)
            a[j]=a[j-1];
        a[j]=temp;
    }
}
int main(){
	char s[21];
	int i;
	int before[20]={0};
	int after[20]={0};
	//输入 
	for(i=0;i<20;i++){
		scanf("%c",&s[i]);
		if(s[i]=='\n') break;
	}
	//读入数组
	int x=i-1;
	for(int j=x;j>=0;j--){
		before[j]=(s[j]-'0');
	}
	int mid,book=0;
	//考虑位数不匹配的情况
	if(s[0]>='5'){
		for(int g=i+1;g>=0;g--)
			s[g+1]=s[g];
		i++;
		s[0]='0';
	} 
	//加倍 
	for(i=i-1;i>=0;i--){
		if(book==1){
			mid=(s[i]-'0')*2+1;
			book=0;
		}else mid=(s[i]-'0')*2;
		if(mid>=10){
			book=1;
			s[i]=mid%10+'0';
		}else{
			s[i]=mid+'0';
		}
	}
	//读入数组
	for(int m=x;m>=0;m--){
		after[m]=(s[m]-'0');
	} 
	//判断
	sort(before,20);
	sort(after,20);
	int ise=0;
	for(int z=0;z<20;z++){
		if(before[z]!=after[z])ise++;
	}
	if(ise>0) printf("No\n%s",s);
	else printf("Yes\n%s",s);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值