[POJ] 1562 Oil Deposits (DFS)

Oil Deposits
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 16655 Accepted: 8917

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2


本题是经典的DFS题,利用DFS求连通块的数量,DFS利用的是递归实现
#include<iostream>
using namespace std;

const int maxn = 100+5;

char pic[maxn][maxn];   //图表
int m, n, idx[maxn][maxn];   //连通分量编号矩阵

//用DFS的方法为连通分量矩阵编号
void DFS(int r, int c, int id)
{
	if(r<0||r>m||c<0||c>=n)return; //overload
	if(idx[r][c]>0||pic[r][c]!='@')return; //no '@' or 已经访问
	idx[r][c]=id; //连通分量编号
	for(int dr=-1; dr<=1;dr++)
		for(int dc=-1;dc<=1;dc++)
			if(dr!=0||dc!=0)DFS(r+dr, c+dc, id);
}

int main()
{
	while(cin>>m>>n&&m!=0)
	{
		for(int i=0;i<m;i++)
			for(int j=0;j<n;j++)
				cin>>pic[i][j];
		for(int i=0;i<m;i++)
			for(int j=0;j<n;j++)
				idx[i][j]=0;
		int cnt=0;
		for(int i=0;i<m;i++)
			for(int j=0;j<n;j++)
				if(idx[i][j]==0&&pic[i][j]=='@')DFS(i,j,++cnt);
		cout<<cnt<<endl;
	}
	return 0;
}

 

可以参考floodfill算法

https://en.wikipedia.org/wiki/Flood_fill 

 

转载于:https://www.cnblogs.com/KennyRom/p/6111869.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值