[SOJ] Babelfish

本文介绍了一种使用字典辅助的外语翻译算法,通过建立英语与虚构外语之间的映射,实现了对输入的外语消息进行翻译。算法首先读取字典条目,然后对输入的外语消息进行翻译,未找到的词汇将被翻译为eh。文章提供了完整的C语言实现代码,包括字典条目的读取、排序以及翻译过程。
摘要由CSDN通过智能技术生成
Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

 

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

 

Sample Input
 Copy sample input to clipboard
dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay
Sample Output
cat
eh
loops

#include<stdio.h>  
#include<string.h>  
#include<stdlib.h>  

char chip[100001][15];  
char bhip[100001][15];  
int  idex[100001];  
char w[15];  
int L,yes;  

int cmp(const void *a,const void *b)  //qsort函数要求的比较函数,函数参数列表必须如此
{  
    return strcmp(bhip[*(int *)a],bhip[*(int *)b]);  //如果a比b大,则返回正数
}

int main()  
{
    int i,j,k,t;  
    L=0;  
    
    while(gets(w)&&w[0]!='\0')  
    {  
        sscanf(w,"%s %s",chip[L],bhip[L]);  
        idex[L]=L;  
        L++;  
    }

    qsort(idex,L,sizeof(idex[0]),cmp);//按字典顺序进行快速排序,cmp为排序的方法

    while(gets(w))//字典查找方法进行二分查找  
    {  
        i=0;  
        j=L-1;  
        yes=0;  
        while(i<=j)  
        {  
            k=(i+j)/2;  
            t=strcmp(bhip[idex[k]],w);  
            if(t>0)  
            {  
                j=k-1;  
            }  
            else if(t<0)  
            {  
                i=k+1;  
            }  
            else  
            {  
                yes=1;  
                break;  
            }  
  
        }  
        if(yes==1)  
            printf("%s\n",chip[idex[k]]);  
        else  
        {  
            printf("eh\n");
        } 
  
    }  

  return 0;
}

  

转载于:https://www.cnblogs.com/KennyRom/p/6250257.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值