第八届ACM省赛 K题 CF

Description

LYD loves codeforces since there are many Russian contests. In an contest lasting for T minutes there are n problems, and for the ith problem you can get aiditi points, where ai indicates the initial points, di indicates the points decreased per minute (count from the beginning of the contest), and ti stands for the passed minutes when you solved the problem (count from the begining of the contest).
Now you know LYD can solve the ith problem in ci minutes. He can't perform as a multi-core processor, so he can think of only one problem at a moment. Can you help him get as many points as he can?

Input

The first line contains two integers n,T(0≤n≤2000,0≤T≤5000).
The second line contains n integers a1,a2,..,an(0<ai≤6000).
The third line contains n integers d1,d2,..,dn(0<di≤50).
The forth line contains n integers c1,c2,..,cn(0<ci≤400).

Output

Output an integer in a single line, indicating the maximum points LYD can get.

Sample Input

3 10
100 200 250
5 6 7
2 4 10

Sample Output

254

题意:有 n道题目,每一道题都有一个初始分值 ai,每个单位时间这道题的分数便会减少 di,而我们可以在 ci时间内做出这道题而得到分数,求在时间 T 内最多可以获得的分数。

思路:先挑单位时间内分数下降最快(di/ci)的做

看别人的博客,但是不理解01背包为什么要排序,每种物品取或者不取不都是固定的吗?后来一想才明白排序只是要让那些一定会选中的先被选(一直刷01背包的模板水题导致自己思维的固定)!!!

贪心+01背包,主要是推出公式

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
struct node
{
    int a;
    int d;
    int c;
}a[2003];
bool cmp(node x,node y)
{
    return (double)(x.d/x.c)>(double)(y.d/y.c);
}
int dp[5005];
int main()
{
    int n,t,maxx;
    while(cin>>n>>t)
    {
        for(int i=1;i<=n;i++)
        {
            cin>>a[i].a;
        }
        for(int i=1;i<=n;i++)
        {
            cin>>a[i].d;
        }
        for(int i=1;i<=n;i++)
        {
            cin>>a[i].c;
        }
        memset(dp,0,sizeof(dp));
        sort(a+1,a+1+n,cmp);
        maxx=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=t;j>=a[i].c;j--)
            {
                dp[j]=max(dp[j],dp[j-a[i].c]+a[i].a-a[i].d*j);
                if(dp[j]>maxx)
                    maxx=dp[j];
            }
        }
        cout<<maxx<<endl;
    }
}

内容概要:本文详细介绍了利用粒子群优化(PSO)算法解决配电网中分布式光伏系统的选址与定容问的方法。首先阐述了问背景,即在复杂的配电网环境中选择合适的光伏安装位置和确定合理的装机容量,以降低网损、减小电压偏差并提高光伏消纳效率。接着展示了具体的PSO算法实现流程,包括粒子初始化、适应度函数构建、粒子位置更新规则以及越界处理机制等关键技术细节。文中还讨论了目标函数的设计思路,将多个相互制约的目标如网损、电压偏差和光伏消纳通过加权方式整合为单一评价标准。此外,作者分享了一些实践经验,例如采用前推回代法进行快速潮流计算,针对特定应用场景调整权重系数,以及引入随机波动模型模拟光伏出力特性。最终实验结果显示,经过优化后的方案能够显著提升系统的整体性能。 适用人群:从事电力系统规划与设计的专业人士,尤其是那些需要处理分布式能源集成问的研究人员和技术人员。 使用场景及目标:适用于希望深入了解如何运用智能优化算法解决实际工程难的人士;旨在帮助读者掌握PSO算法的具体应用方法,从而更好地应对配电网中分布式光伏系统的选址定容挑战。 其他说明:文中提供了完整的Matlab源代码片段,便于读者理解和复现研究结果;同时也提到了一些潜在改进方向,鼓励进一步探索和创新。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值