第八届ACM省赛 K题 CF

Description

LYD loves codeforces since there are many Russian contests. In an contest lasting for T minutes there are n problems, and for the ith problem you can get aiditi points, where ai indicates the initial points, di indicates the points decreased per minute (count from the beginning of the contest), and ti stands for the passed minutes when you solved the problem (count from the begining of the contest).
Now you know LYD can solve the ith problem in ci minutes. He can't perform as a multi-core processor, so he can think of only one problem at a moment. Can you help him get as many points as he can?

Input

The first line contains two integers n,T(0≤n≤2000,0≤T≤5000).
The second line contains n integers a1,a2,..,an(0<ai≤6000).
The third line contains n integers d1,d2,..,dn(0<di≤50).
The forth line contains n integers c1,c2,..,cn(0<ci≤400).

Output

Output an integer in a single line, indicating the maximum points LYD can get.

Sample Input

3 10
100 200 250
5 6 7
2 4 10

Sample Output

254

题意:有 n道题目,每一道题都有一个初始分值 ai,每个单位时间这道题的分数便会减少 di,而我们可以在 ci时间内做出这道题而得到分数,求在时间 T 内最多可以获得的分数。

思路:先挑单位时间内分数下降最快(di/ci)的做

看别人的博客,但是不理解01背包为什么要排序,每种物品取或者不取不都是固定的吗?后来一想才明白排序只是要让那些一定会选中的先被选(一直刷01背包的模板水题导致自己思维的固定)!!!

贪心+01背包,主要是推出公式

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
struct node
{
    int a;
    int d;
    int c;
}a[2003];
bool cmp(node x,node y)
{
    return (double)(x.d/x.c)>(double)(y.d/y.c);
}
int dp[5005];
int main()
{
    int n,t,maxx;
    while(cin>>n>>t)
    {
        for(int i=1;i<=n;i++)
        {
            cin>>a[i].a;
        }
        for(int i=1;i<=n;i++)
        {
            cin>>a[i].d;
        }
        for(int i=1;i<=n;i++)
        {
            cin>>a[i].c;
        }
        memset(dp,0,sizeof(dp));
        sort(a+1,a+1+n,cmp);
        maxx=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=t;j>=a[i].c;j--)
            {
                dp[j]=max(dp[j],dp[j-a[i].c]+a[i].a-a[i].d*j);
                if(dp[j]>maxx)
                    maxx=dp[j];
            }
        }
        cout<<maxx<<endl;
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值