hdu_3123_GCC

The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m

InputThe first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.
OutputOutput the answer of (0! + 1! + 2! + 3! + 4! + ... + n!)%m.

Constrains
0 < T <= 20
0 <= n < 10^100 (without leading zero)
0 < m < 1000000
Sample Input

1
10 861017

Sample Output

593846

唬人的题目,当x>=m, x! =0 mod m
我们就是在求小于m的 ∑x!
提取公因式化简得
1+(1*2)+(1*2*3)+.....+(1*2*3*....*x)=1*(1+2*(1+3*(.....x-1*(1+x))))
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
int main()
{
    char n[105];
    int m,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",n);
        getchar();
        scanf("%d",&m);
        int s=strlen(n);
        int n1=0;
        for(int i=0;i<s;i++)
        {
            n1*=10;
            n1+=n[i]-'0';
            if(n1>=m)
                break;
        }
        long long ans;
        if(n1>=m)
        {
            ans=m-1;
            for(int i=m-2;i>=1;i--)
            {
                ans=(ans+1)%m*i%m;
            }
        }
        else
        {
            ans=n1;
            for(int i=n1-1;i>=1;i--)
            {
                ans=(ans+1)%m*i%m;
            }
        }
        ans++;
        cout<<ans%m<<endl;

    }
}

  

转载于:https://www.cnblogs.com/ygtzds/p/7900544.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值