hdu 6197 array array array

array array array

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 459    Accepted Submission(s): 282


Problem Description
One day, Kaitou Kiddo had stolen a priceless diamond ring. But detective Conan blocked Kiddo's path to escape from the museum. But Kiddo didn't want to give it back. So, Kiddo asked Conan a question. If Conan could give a right answer, Kiddo would return the ring to the museum.
Kiddo: "I have an array A and a number k , if you can choose exactly k elements from A and erase them, then the remaining array is in non-increasing order or non-decreasing order, we say A is a magic array. Now I want you to tell me whether A is a magic array. " Conan: "emmmmm..." Now, Conan seems to be in trouble, can you help him?
 

 

Input
The first line contains an integer T indicating the total number of test cases. Each test case starts with two integers n and k in one line, then one line with n integers: A1,A2An .
1T20
1n105
0kn
1Ai105
 

 

Output
For each test case, please output "A is a magic array." if it is a magic array. Otherwise, output "A is not a magic array." (without quotes).
 

 

Sample Input
3 4 1 1 4 3 7 5 2 4 1 3 1 2 6 1 1 4 3 5 4 6
 

 

Sample Output
A is a magic array. A is a magic array. A is not a magic array.
 

 

Source
 
这道题转换之后就是求最长上升子序列长度,此外,发现了一种二分求LIS方法。
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<vector>
#include<cmath>
#include<string>
#define LL long long  
const int maxn=1e5+5;
using namespace std;
int a[maxn],b[maxn],c[maxn];
int n;
int LIS(int *d){
    memset(c,0,sizeof(c));
    c[1]=d[1];
    int l,r,mid,len=1;
    for(int i=2;i<=n;i++){
        l=1;
        r=len;
        while(l<=r){    
        mid=(l+r)/2;
        if(c[mid]<=d[i]) l=mid+1;
        else  r=mid-1;
        }
        c[l]=d[i];
        if(l>len) len++;

    }
    return len;
}
int main()
{
    int T;
    scanf("%d",&T);
    int k;
    while(T--)
    {
        scanf("%d%d",&n,&k);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            b[i]=-a[i];
        }
        int maxn=max(LIS(a),LIS(b));

        if(n-maxn>k)
        printf("A is not a magic array.\n");
        else 
        printf("A is a magic array.\n");
    }   
    return 0;
}

  

转载于:https://www.cnblogs.com/ygtzds/p/7507568.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值