poj2010 Moo University - Financial Aid 优先队列

Description

Bessie noted that although humans have many universities they can attend, cows have none. To remedy this problem, she and her fellow cows formed a new university called The University of Wisconsin-Farmside,"Moo U" for short. 

Not wishing to admit dumber-than-average cows, the founders created an incredibly precise admission exam called the Cow Scholastic Aptitude Test (CSAT) that yields scores in the range 1..2,000,000,000. 

Moo U is very expensive to attend; not all calves can afford it.In fact, most calves need some sort of financial aid (0 <= aid <=100,000). The government does not provide scholarships to calves,so all the money must come from the university's limited fund (whose total money is F, 0 <= F <= 2,000,000,000). 

Worse still, Moo U only has classrooms for an odd number N (1 <= N <= 19,999) of the C (N <= C <= 100,000) calves who have applied.Bessie wants to admit exactly N calves in order to maximize educational opportunity. She still wants the median CSAT score of the admitted calves to be as high as possible. 

Recall that the median of a set of integers whose size is odd is the middle value when they are sorted. For example, the median of the set {3, 8, 9, 7, 5} is 7, as there are exactly two values above 7 and exactly two values below it. 

Given the score and required financial aid for each calf that applies, the total number of calves to accept, and the total amount of money Bessie has for financial aid, determine the maximum median score Bessie can obtain by carefully admitting an optimal set of calves. 

Input

* Line 1: Three space-separated integers N, C, and F 

* Lines 2..C+1: Two space-separated integers per line. The first is the calf's CSAT score; the second integer is the required amount of financial aid the calf needs 

Output

* Line 1: A single integer, the maximum median score that Bessie can achieve. If there is insufficient money to admit N calves,output -1. 

Sample Input

3 5 70
30 25
50 21
20 20
5 18
35 30

Sample Output

35

Hint

Sample output:If Bessie accepts the calves with CSAT scores of 5, 35, and 50, the median is 35. The total financial aid required is 18 + 30 + 21 = 69 <= 70. 
 
中文题意:有c头奶牛,每头奶牛有两个属性socre,money;从中选取n头奶牛,n一定是奇数,使得这n头奶牛的money属性的和小于等于f,在满足这个条件的前提下,使得这n头奶牛的中位数(score属性的中位数)尽可能的大,并输出score的中位数,如果不能满足前提条件就输出-1;
思路:将c头奶牛按照score属性从大到小进行排序,枚举遍历,在第i头奶牛的前i-1头中找出n/2头奶牛(money属性值最小的前n/2奶牛),同理在第i头奶牛后找出n/2头奶牛,使得money和最小。第一个满足前n/2头奶牛money和加上后n/2头奶牛money和加上第i头奶牛的money<=f,输出第i头奶牛的score即可;否则输出-1;
超时代码:

#include<iostream>
#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;
struct node{
int b,d;
}a[100005];
int cmp(struct node x,struct node y){
if(x.b==y.b) return x.d<y.d;
else return x.b>y.b;
}
int main(){
int n,c,f;
cin>>n>>c>>f;
for(int i=0;i<c;i++){
scanf("%d%d",&a[i].b,&a[i].d);
}
sort(a,a+c,cmp);
int plug=0;
//for(int i=0;i<c;i++)
///printf("%d %d\n",a[i].b,a[i].d);
if(n==1){
for(int i=0;i<c;i++){
if(a[i].d<=f){
cout<<a[i].b<<endl;
plug=1;
break;
}
}
}
else
for(int i=n/2;i<=c-1-n/2;i++){
priority_queue<int ,vector<int>,greater<int> >q;//前面
priority_queue<int ,vector<int>,greater<int> >p;//后面
for(int j=0;j<i;j++)
q.push(a[j].d);
int cost=0;
for(int j=0;j<n/2;j++)
cost+=q.top(),q.pop();
for(int j=i+1;j<c;j++)
p.push(a[j].d);
for(int j=0;j<n/2;j++)
cost+=p.top(),p.pop();
if(cost+a[i].d<=f){
cout<<a[i].b<<endl;
plug=1;
//cout<<1<<" "<<cost<<endl;
break;
}
//cout<<1<<" "<<cost<<endl;
if(plug==0) cout<<"-1"<<endl;
}
return 0;
}

这么写,会有很多次不必要的push()操作,使得超时,其中push()操作是n^2级别的;

真正的AC代码,push()操作是n级别的:

#include<iostream>
#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;
struct node{
int score,money;
}cow[100005];
int before[100005],after[100005];//分别表示前面部分的最小,和后面部分的最小,包括i本身
int cmp(struct node a,struct node b){
if(a.score==b.score) return a.money<b.money;
else return a.score>b.score;
}
int main(){
int n,c,f;
cin>>n>>c>>f;
for(int i=0;i<c;i++)
scanf("%d%d",&cow[i].score,&cow[i].money);
sort(cow,cow+c,cmp);
int sum=0;
priority_queue<int >q;
for(int i=0;i<n/2;i++) q.push(cow[i].money),sum+=cow[i].money;
before[n/2-1]=sum;
for(int i=n/2;i<=c-1-n/2;i++){
sum+=cow[i].money;
q.push(cow[i].money);
sum-=q.top();
q.pop();
before[i]=sum;
}
sum=0;
while(!q.empty()) q.pop();
for(int i=c-1;i>c-1-n/2;i--) q.push(cow[i].money),sum+=cow[i].money;
after[c-n/2]=sum;
for(int i=c-1-n/2;i>n/2;i--) {
sum+=cow[i].money;
q.push(cow[i].money);
sum-=q.top();
q.pop();
after[i]=sum;
}
int plug=0;
for(int i=n/2;i<=c-1-n/2;i++){
if(before[i-1]+after[i+1]+cow[i].money<=f){
plug=1;
cout<<cow[i].score<<endl;
break;
}
}
if(!plug) cout<<"-1"<<endl;
return 0;
}

转载于:https://www.cnblogs.com/sunjianzhao/p/11600003.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 内容概要 《计算机试卷1》是一份综合性的计算机基础和应用测试卷,涵盖了计算机硬件、软件、操作系统、网络、多媒体技术等多个领域的知识点。试卷包括单选题和操作应用两大类,单选题部分测试学生对计算机基础知识的掌握,操作应用部分则评估学生对计算机应用软件的实际操作能力。 ### 适用人群 本试卷适用于: - 计算机专业或信息技术相关专业的学生,用于课程学习或考试复习。 - 准备计算机等级考试或职业资格认证的人士,作为实战演练材料。 - 对计算机操作有兴趣的自学者,用于提升个人计算机应用技能。 - 计算机基础教育工作者,作为教学资源或出题参考。 ### 使用场景及目标 1. **学习评估**:作为学校或教育机构对学生计算机基础知识和应用技能的评估工具。 2. **自学测试**:供个人自学者检验自己对计算机知识的掌握程度和操作熟练度。 3. **职业发展**:帮助职场人士通过实际操作练习,提升计算机应用能力,增强工作竞争力。 4. **教学资源**:教师可以用于课堂教学,作为教学内容的补充或学生的课后练习。 5. **竞赛准备**:适合准备计算机相关竞赛的学生,作为强化训练和技能检测的材料。 试卷的目标是通过系统性的题目设计,帮助学生全面复习和巩固计算机基础知识,同时通过实际操作题目,提高学生解决实际问题的能力。通过本试卷的学习与练习,学生将能够更加深入地理解计算机的工作原理,掌握常用软件的使用方法,为未来的学术或职业生涯打下坚实的基础。
### 内容概要 这份《计算机试卷1》包含多个部分,主要覆盖了计算机基础知识、操作系统应用、文字处理、电子表格、演示文稿制作、互联网应用以及计算机多媒体技术。试卷以单选题开始,涉及计算机历史、基本概念、硬件组成、软件系统、网络协议等。接着是操作应用部分,要求考生在给定的软件环境中完成一系列具体的计算机操作任务。 ### 适用人群 本试卷适用于计算机科学与技术、信息技术相关专业的学生,以及准备计算机水平考试或职业资格认证的人士。它适合那些希望检验和提升自己计算机操作能力的学习者,也适用于教育工作者作为教学评估工具。 ### 使用场景及目标 1. **学习评估**:作为教育机构的课程评估工具,帮助教师了解学生对计算机基础知识的掌握程度。 2. **自学检验**:供个人自学者检验自己的计算机操作技能和理论知识,为进一步学习提供方向。 3. **职业发展**:为职场人士提供计算机技能的自我提升途径,增强其在信息时代的竞争力。 4. **考试准备**:为准备计算机相关考试的考生提供实战演练的机会,加强考试自信。 5. **教学资源**:教师可以将其作为教学资源,设计课程和实验,提高教学效果。 试卷的目标是通过理论知识的测试和实践技能的操作,全面提升考生的计算机应用能力。考生应掌握从基础的计算机组成原理到复杂的数据处理、演示文稿制作、网络应用以及多媒体技术处理等多方面技能。通过本试卷的学习与练习,考生将能够更加熟练地使用计算机解决实际问题,为未来的学术或职业生涯打下坚实的基础。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值