无向边的二分匹配

Jimmy is studying Advanced Graph Algorithms at his university. His most recent assignment is to find a maximum matching in a special kind of graph. This graph is undirected, has N vertices and each vertex has degree 3. Furthermore, the graph is 2-edge-connected (that is, at least 2 edges need to be removed in order to make the graph disconnected). A matching is a subset of the graph’s edges, such that no two edges in the subset have a common vertex. A maximum matching is a matching having the maximum cardinality. 
  Given a series of instances of the special graph mentioned above, find the cardinality of a maximum matching for each instance. 
Input
The first line of input contains an integer number T, representing the number of graph descriptions to follow. Each description contains on the first line an even integer number N (4<=N<=5000), representing the number of vertices. Each of the next 3*N/2 lines contains two integers A and B, separated by one blank, denoting that there is an edge between vertex A and vertex B. The vertices are numbered from 1 to N. No edge may appear twice in the input. 
Output
For each of the T graphs, in the order given in the input, print one line containing the cardinality of a maximum matching. 
Sample Input
2
4
1 2
1 3
1 4
2 3
2 4
3 4
4
1 2
1 3
1 4
2 3
2 4
3 4
Sample Output
2
2



#include<iostream>
#include<cstring>
#include<vector>
#include<cstdio>
using namespace std;
int used[5005],girl[5005],n;
vector<int> line[5005];
int find(int x)
{
    for(int i=0;i<line[x].size();i++)
    {
        if(used[line[x][i]]==0)
        {
            used[line[x][i]]=1;
            if(girl[line[x][i]]==0||find(girl[line[x][i]]))
            {
                girl[line[x][i]]=x;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int T,tot,x,y;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        memset(girl,0,sizeof(girl));
        for(int i=0;i<n;i++)
        {
            line[i].clear();
        }
        for(int i=1;i<=3*n/2;i++)
        {
            scanf("%d %d",&x,&y);
            line[x-1].push_back(y-1);
            line[y-1].push_back(x-1);
        }
        tot=0;
        for(int i=0;i<n;i++)
        {
            memset(used,0,sizeof(used));
            if(find(i))
                tot++;
        }
        printf("%d\n",tot/2);
    }
}

 

转载于:https://www.cnblogs.com/Leozi/p/10835492.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值