USACO2012 Haybale stacking /// 区间表示法 oj21556

题目大意:
N个方块 标号1~N 
K个操作 操作a b 表示标号a~b区间每位多加一个方块
Input

* Line 1: Two space-separated integers, N  K.

* Lines 2..1+K: Each line contains one of FJ's instructions in the form of two space-separated integers A  B (1 ≤ A ≤ B≤ N).

Output

* Line 1: The median height of a stack after Bessie completes the instructions.

Sample Input

7 4
5 5
2 4
4 6
3 5

Sample Output

1

 

即 有N = 7个方块,发出K = 4个指令。第一条指令是添加方块在堆栈5,第二个是添加方块到堆栈2..4等

输出细节:

操作完成后,堆栈的高度为 0, 1, 2, 3, 3, 1, 0。

中间堆栈高度为1,因为1是排序的顺序中的0, 0, 1, 1, 2, 3, 3。

 

区间表示法

#include <stdio.h>
#include <string.h>
#include <algorithm>
int flag[1000000]={0};
using namespace std;
int main()
{
    int n,k;
    scanf("%d%d",&n,&k);
    while(k--)
    {
        int a,b;
        scanf("%d%d",&a,&b);
        flag[a]++;
        flag[b+1]--;
    }
    int sum=0;
    for(int i=0;i<=n;i++)
    {
        sum+=flag[i];
        flag[i]=sum;
    }
    sort(flag,flag+n+1);
    printf("%d\n",flag[n/2+1]);

    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/zquzjx/p/8321466.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值