1044 火星数字 (20 分)

火星人是以 13 进制计数的:

  • 地球人的 0 被火星人称为 tret。
  • 地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
  • 火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数 N(<),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:

4
29
5
elo nov
tam

输出样例:

hel mar
may
115
13
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int main()
{
    string one[13] = { "tret" ,"jan", "feb", "mar","apr","may", "jun", "jly","aug", "sep", "oct", "nov","dec" },
        two[13] = { "tret","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou" };
    int n, sum = 0,res;
    string m;
    cin >> n;
    getchar();    //清除缓存(之前的回车键)
    while (n--) {
        getline(cin, m);
        if (isdigit(m[0])) {        //地球->火星
            res = atoi(m.c_str());    
            if (res/13)
                cout << two[res/13];
            if (res / 13 && res % 13)
                cout << " "<< one[res % 13];
            if (!(res/13))
                cout << one[res % 13];
            cout << endl;
        }
        else {                    //火星->地球
            for (int i = 0; i < 13; i++) {
                if (m.substr(m.length() - 3,m.length()) == one[i]) {
                    sum += i;
                    break;
                }            
                else if (m.substr(m.length() - 3, m.length()) == two[i]) {
                    sum += (i*13);
                    break;
                }
            }
            if (m.length() > 4) {
                for (int i = 0; i < 13; i++) {
                    if (m.substr(0, 3) == two[i]) {
                        sum += i * 13;
                        break;
                    }
                }
            }
            cout << sum << endl;
            sum = 0;
        }
    }
    return 0;
}

 


用C++写,https://blog.csdn.net/qq_40946921/article/details/81144280

转载于:https://www.cnblogs.com/TBhacker/p/11220218.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值