Ignatius and the Princess III

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13975    Accepted Submission(s): 9844


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
  
  
4 10 20
 

Sample Output
  
  
5 42 627
 
#include <stdio.h>
#include <string.h>
int bei[121][121];

int init(int m,int n)
{
	int sum, sum2;
	if (bei[m][n] > 0)
	{
		return bei[m][n];
	}
	else
	{
		if(n==1||m==1)
		{
			bei[m][n] = 1;
			return 1;
		}
		else if(m==n)
		{
			sum = init(m, n - 1) + 1;
			bei[m][n] = sum;
			return sum;
		}
		else if (m<n)
		{
			sum = init(m, m);
			bei[m][n] = sum;
			return sum;
		}
		else
		{
			sum = init(m - n, n);
			sum2 = init(m, n - 1);
			bei[m][n] = sum + sum2;
			return sum + sum2;
		}
	}

}


int main()
{
    int n;
 	while(scanf("%d",&n)!=EOF)
	{
		memset(bei, 0, sizeof(bei));
        printf("%d\n",init(n,n));
 	}	
	return 0;
}

本来用递归的方法发现超时,现在是改进版!基本意思还是看到网上的资料

(一)方法一——递归法

    根据n和m的关系,考虑下面几种情况:

    (1)当n=1时,不论m的值为多少(m>0),只有一种划分,即{1};

    (2)当m=1时,不论n的值为多少(n>0),只有一种划分,即{1,1,....1,1,1};

    (3)当n=m时,根据划分中是否包含n,可以分为两种情况:

        (a)划分中包含n的情况,只有一个,即{n};

        (b)划分中不包含n的情况,这时划分中最大的数字也一定比n小,即n的所有(n-1)划分;

        因此,f(n,n) = 1 + f(n, n - 1)。

    (4)当n<m时,由于划分中不可能出现负数,因此就相当于f(n,n);

    (5)当n>m时,根据划分中是否包含m,可以分为两种情况:

        (a)划分中包含m的情况,即{m,{x1,x2,x3,...,xi}},其中{x1,x2,x3,...,xi}的和为n-m,可能再次出现m,因此是(n-m)的m划分,因此这种划分个数为f(n-m, m);

        (b)划分中不包含m的情况,则划分中所有值都比m小,即n的(m-1)划分,个数为f(n, m - 1);

        因此,f(n,m) = f(n - m,m) + f(n, m - 1)。



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值