Problem A: 【简单计算】

Problem A: 【简单计算】

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 8   Solved: 3
[ Submit][ Status][ Web Board]

Description

有一个n+2个元素a[0], a[1], ..., a[n+1] (n <= 3000, -1000 <= a[i] <=1000)构成的数列. 
已知对i=1, 2, ..., n有a[i] = (a[i-1] + a[i+1])/2 - c[i]. 

给定a0, a[n+1], c[1], ... , c[n]. 写一个程序计算a[1]. 

Input

第一行是整数n. 接下来两行是a[0]和a[n+1], 其小数点后有两位数字. 其后的n行为c[i](同样是两位小数), 每行一个数.

Output

输出为a[1], 格式与a[0], a[n+1]相同.

Sample Input

1
50.50
25.50
10.15

Sample Output

27.85

HINT

额额,数学题!


#include<stdio.h>
#include<string.h>

int main()
{
    int  n, i;
    double first, final, sum, temp, ans;
    while(scanf("%d", &n)!=EOF)
    {
        scanf("%lf", &first);
        scanf("%lf", &final);
        for(i=1,sum=0; i<=n; ++i)
        {
            scanf("%lf", &temp);
            sum += 2.0*(n+1-i)*temp;
        }
        
        ans = n*first+final-sum;
        printf("%.2lf\n", ans/(n+1));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值