GCC(阶乘和求余,很重要)

GCC

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 4162    Accepted Submission(s): 1365


Problem Description
The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m
 

Input
The first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.
 

Output
Output the answer of (0! + 1! + 2! + 3! + 4! + ... + n!)%m.

Constrains
0 < T <= 20
0 <= n < 10^100 (without leading zero)
0 < m < 1000000
 

Sample Input
  
  
1 10 861017
 

Sample Output
  
  
593846
 

Source
 
阶乘和求余,见过快速幂求余,见过阶乘求余,没见过阶乘和求

余,公式我也看不懂!就知道前面,如果stl>=7就说明n是一个非

大的数的一个因子,当这个数大于n时,其余数为0!所 以要求

n以及n以下的阶乘和
#include<cstdio>
#include<cstring>
#include<string>
#include<iostream>
using namespace std;
int main()
{
    long long ans,sum,f;
    int t,stl,n,i;
    char c[500];
    cin>>t;
    while(t--)
    {
        cin>>c>>n;
        stl=strlen(c);
        if(stl>=7)
        {
            ans=n;
        }
        else
        {
            ans=0;
            for(i=0;i<stl;i++)
            {
                ans=ans*10+(c[i]-'0');
            }
        }
        for(f=i=1,sum=0;i<=ans;i++)
        {
            f=f*i%n;
            sum=(sum+f)%n;
        }
        sum=(sum+1)%n;
        cout<<sum<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值