Ice_cream's world I(并查集之判断有几个圈)

Ice_cream's world I

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 746    Accepted Submission(s): 433


Problem Description
ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
 

Input
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.
 

Output
Output the maximum number of ACMers who will be awarded.
One answer one line.
 

Sample Input
  
  
8 10 0 1 1 2 1 3 2 4 3 4 0 5 5 6 6 7 3 6 4 7
 

Sample Output
  
  
3
 

Author
Wiskey
 

Source
 

并查集本身是集合的应用,但是由于每次只告诉你两个点之间有墙,只要当这两个点的父节点是同一个,并且再次有墙时,就把结果加1,因为这个时候肯定就会产生一个区域。

#include<cstdio>
#include<iostream>
using namespace std;
int a[10010],ans;
int Find(int x)
{
    int r=x;
    while(r!=a[r])
        r=a[r];

   /* int i=x,j;
    while(a[i]!=r)
    {
        j=a[i];
        a[i]=r;
        i=j;
    }*/
    return r;
}//这个就是找老大的函数,什么时候停止?就是当一个人的老大是他自己的时候!
void mix(int x,int y)
{
    int fx=Find(x),fy=Find(y);//首先要找到他们各自的老大
    if(fx==fy)//如果他们的老大不相等,要合并就必须其中的一个老大向另外一个老大称老大
    {
        ans++;
    }
    else
    {
        a[fy]=fx;
    }
}
int main()
{
    int n,m,i,b,c;
    while(cin>>n>>m)
    {
        ans=0;
        for(i=0;i<=n-1;i++)
        {
            a[i]=i;
        }
        for(i=1;i<=m;i++)
        {
            cin>>b>>c;
            mix(b,c);
        }
        cout<<ans<<endl;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值