Guessing Game

Problem F: Guessing Game

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 20   Solved: 6
[ Submit][ Status][ Web Board]

Description

Stan and Ollie are playing a guessing game. Stan thinks of a number between 1 and 10 and Ollie guesses what the number might be. After each guess, Stan indicates whether Ollie's guess is too high, too low, or right on.

After playing several rounds, Ollie has become suspicious that Stan cheats; that is, that he changes the number between Ollie's guesses. To prepare his case against Stan, Ollie has recorded a transcript of several games. You are to determine whether or not each transcript proves that Stan is cheating.

Standard input consists of several transcripts. Each transcript consists of a number of paired guesses and responses. A guess is a line containing single integer between 1 and 10, and a response is a line containing "too high", "too low", or "right on". Each game ends with "right on". A line containing 0 follows the last transcript.

For each game, output a line "Stan is dishonest" if Stan's responses are inconsistent with the final guess and response. Otherwise, print "Stan may be honest".

Input

Output

Sample Input

10
too high
3
too low
4
too high
2
right on
5
too low
7
too high
6
right on
0

Sample Output

Stan is dishonest
Stan may be honest

HINT


#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int main()
{
    int n,mx,mn,flag;
    char s[30];
    flag=0;
    mx=11;mn=-1;
    while(scanf("%d",&n)&&n)
    {
        getchar();
        gets(s);
        if(strcmp(s,"right on")==0)
        {
            if(flag==0&&n<mx&&n>mn)
            {
                cout<<"Stan may be honest"<<endl;
            }
            else
            {
                cout<<"Stan is dishonest"<<endl;
            }
            mx=11;
            mn=-1;
            flag=0;
        }
        if(strcmp(s,"too high")==0)
        {
            if(n<=mn)
            {
                flag=1;
            }
            else if(n<mx)
            {
                mx=n;
            }
        }
        if(strcmp(s,"too low")==0)
        {
            if(n>=mx)
            {
                flag=1;
            }
            else if(n>mn)
            {
                mn=n;
            }
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值