The Unique MST(次小生成树)

The Unique MST
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 22899 Accepted: 8147

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

Source

这一题跟上面那道题一样,只是这里如果不一样,让你输出最小生成树的值!



#include<cstdio>
#include<iostream>
#include<cstring>
const int infinity=0x3f3f3f3f;
const int maxnum=120;
using namespace std;
int nodenum,result;
int map1[maxnum][maxnum],visited[maxnum],low[maxnum];//最小生成树基本变量
int mmax[maxnum][maxnum],pre[maxnum],connect[maxnum][maxnum];//次小生成树必须变量
void prim()
{
    int i,j,Min,pos=1,fa;
    result=0;
    memset(visited,0,sizeof(visited));//初始化都未标记
    memset(mmax,0,sizeof(mmax));//*****mmax初始化为0*****
    for(i=1;i<=nodenum;i++)
    {
        low[i]=map1[pos][i];
        pre[i]=pos;//*****把所有的点的前节点记录为1*****
    }
    low[pos]=0;
    visited[pos]=1;//把1号作为起点
    for(i=2;i<=nodenum;i++)//这个i没有其他的意思就是一个循环次数
    {
        Min=infinity;pos=-1;//从1号开始找最小的边
        for(j=1;j<=nodenum;j++)
        {
            if(!visited[j]&&Min>low[j])
            {
                Min=low[j];
                pos=j;
            }
        }
        if(pos==-1)
        {
            return ;
        }
        visited[pos]=1;//做到与1os号最近的边
        result+=Min;//加权值
        fa=pre[pos];//*****取得这个点的前节点*****
        connect[fa][pos]=connect[pos][fa]=0;//*****让前节点与当前点不是联通的!
        mmax[fa][pos]=Min;//*****设置前点与当前点的距离为Min*****
        for(j=1;j<=nodenum;j++)
        {
            if(!visited[j]&&low[j]>map1[pos][j])
            {
                low[j]=map1[pos][j];//这个就是替换未被标记的最小权值!
                pre[j]=pos;//*****更新此时所有被更换权值节点的前节点为pos*****
            }
        }
        //*****以下为次小生成树新增*****
        for(j=1;j<=nodenum;j++)
        {
            mmax[j][pos]=mmax[fa][pos]>mmax[j][fa]?mmax[fa][pos]:mmax[j][fa];//更新次小权值
        }
        //*****以上为次小生成树新增*****
    }
    return ;
}
int main()
{
    int t,m,i,j,a,b,c,flag;
    cin>>t;
    while(t--)
    {
        memset(map1,infinity,sizeof(map1));
    /*   for(i=1;i<=nodenum;i++)
       {
           for(j=1;j<=nodenum;j++)
           {
               map1[i][j]=infinity;
           }
       }把这个替换成上面那个就WA了不知道为什么,以后注意一点!
       */
        memset(connect,0,sizeof(connect));//*****
        cin>>nodenum>>m;
        while(m--)
        {
            cin>>a>>b>>c;
            if(c<map1[a][b])
            {
                map1[a][b]=map1[b][a]=c;
                connect[a][b]=connect[b][a]=1;//*****
            }
        }
        prim();
        flag=0;
        for(i=1;i<=nodenum;i++)
        {
            for(j=1;j<=nodenum;j++)
            {
                if(connect[i][j]==0||map1[i][j]==infinity)
                {
                    continue;
                }
                if(map1[i][j]==mmax[i][j])
                {
                    flag++;
                }
            }
        }
       if(flag==0)
       {
           cout<<result<<endl;
       }
       else
       {
           cout<<"Not Unique!"<<endl;
       }
    }
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
prim_mst构造最小生成树的思想是通过贪心算法逐步选择边来构建最小生成树。具体步骤如下: 1. 创建一个空的最小生成树MST和一个空的集合visited,用于存储已经访问过的顶点。 2. 选择一个起始顶点作为根节点,并将其加入visited集合。 3. 从根节点开始,遍历与根节点相邻的边,并选择权重最小的边。 4. 将选择的边加入MST,并将边的另一个顶点加入visited集合。 5. 重复步骤3和步骤4,直到visited集合包含所有顶点。 6. 最终得到的MST就是原图的最小生成树。 以下是使用prim_mst构造最小生成树的示例代码: ```python import numpy as np def prim_mst(graph): num_vertices = len(graph) MST = [] visited = set() # 选择起始顶点 start_vertex = 0 visited.add(start_vertex) while len(visited) < num_vertices: min_weight = np.inf min_edge = None # 遍历已访问的顶点 for vertex in visited: # 遍历与已访问顶点相邻的边 for neighbor, weight in enumerate(graph[vertex]): # 如果边的另一个顶点未访问且权重更小,则更新最小边 if neighbor not in visited and weight < min_weight: min_weight = weight min_edge = (vertex, neighbor) # 将最小边加入MST,并将边的另一个顶点加入visited集合 MST.append(min_edge) visited.add(min_edge[1]) return MST # 示例输入矩阵 graph = np.array([[0, 192, 344, 0, 0, 0, 0, 0, 0, 0, 0], [192, 0, 309, 0, 555, 0, 0, 0, 0, 0, 0], [344, 309, 0, 499, 0, 0, 0, 0, 0, 0, 0], [0, 0, 499, 0, 840, 0, 229, 286, 0, 0, 0], [0, 555, 0, 840, 0, 237, 0, 0, 0, 0, 0]]) # 构造最小生成树 MST = prim_mst(graph) print("Minimum Spanning Tree:") for edge in MST: print(edge) ``` 输出结果为最小生成树的边集合。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值