Tempter of the Bone(DFS+剪枝)

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 87885    Accepted Submission(s): 23909


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
NO YES
  这一题为什么不能用bfs写呢?因为bfs是求最短时间!这里是让你求恰好是否在t秒到出口,你可以在访问一个点之后再次访问一个点

#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
#include<cmath>
const int N=10;
using namespace std;
char map1[N][N];
int vis[N][N];
int to[4][2]={1,0,-1,0,0,1,0,-1};
int n,m,ex,ey,t,escape;
void dfs(int sx,int sy,int cnt)
{
    int i,temp;
    if(sx==ex&&sy==ey&&cnt==t)
    {
        escape=1;
        return;
    }
    if(sx<=0||sx>n||sy<=0||sy>m)
    {
        return ;
    }
    /*
    奇偶剪枝:根据题目,doggie必须在第t秒到达门口。
    也就是需要走t-1步。设doggie开始的位置为(sx,sy),
    目标位置为(ex,ey).如果abs(ex-x)+abs(ey-y)为偶数,
    则abs(ex-x)和abs(ey-y)奇偶性相同,所以需要走偶数步;
    当abs(ex-x)+abs(ey-y)为奇数时,
    则abs(ex-x)和abs(ey-y)奇偶性不同,
    到达目标位置就需要走奇数步。
    先判断奇偶性再搜索可以节省很多时间,
    不然的话容易超时。t-sum为到达目标位置还需要多少步。
    因为题目要求doggie必须在第t秒到达门的位置,
    所以(t-cnt)和abs(ex-x)+abs(ey-y)的奇偶性必然相同。
    因此temp=(t-cnt)-abs(ex-x)+abs(ey-y)必然为偶数。*/

    temp = (t-cnt) - abs(sx-ex) - abs(sy-ey);
    if(temp<0||temp&1)
    {
        return;
    }
    for(i=0;i<4;i++)
    {
        if(map1[sx+to[i][0]][sy+to[i][1]]!='X')
        {
            map1[sx+to[i][0]][sy+to[i][1]]='X';
            dfs(sx+to[i][0],sy+to[i][1],cnt+1);
            if(escape)
            {
                return;
            }
            map1[sx+to[i][0]][sy+to[i][1]]='.';
        }
    }
    return;
}
int main()
{
    int i,j,sx,sy,num_wall;
    while(cin>>n>>m>>t&&n+m+t)
    {
        escape=0;
        num_wall=0;
        memset(vis,0,sizeof(vis));
        memset(map1,0,sizeof(map1));
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
            {
                cin>>map1[i][j];
                if(map1[i][j]=='S')
                {
                    sx=i;
                    sy=j;
                }
                if(map1[i][j]=='X')
                {
                    num_wall++;
                }
                if(map1[i][j]=='D')
                {
                    ex=i;
                    ey=j;
                }
            }
        }
        if(n*m-num_wall<=t)
        {
            cout<<"NO"<<endl;
            continue;
        }
        map1[sx][sy]='X';
        dfs(sx,sy,0);
        if(escape)
        {
            cout<<"YES"<<endl;
        }
        else
        {
            cout<<"NO"<<endl;
        }
    }
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值