PE 题目 NBUT 1226 A Simple Triangle

A Simple Triangle

In this problem you need to make a triangle ,just like the sample out. The element in the ith row and jth column

should be the product(乘积) of i and j.

Input
The first line of input is an integer C which indicate the number of test cases. 
Then C test cases follow.Each test case contains an integer N (1<=N<=20) in a line which mentioned above.
Output
For each test case, print out the triangle. the triangle separated by a blank line. 
If the product is more than 9 (product > 9) you should print a space, or you should print two space.The final number of each line don't need print space. 
Sample Input
3
5
6
7
Sample Output
1  2  3  4  5
2  4  6  8
3  6  9
4  8
5

1  2  3  4  5  6
2  4  6  8  10
3  6  9  12
4  8  12
5  10
6

1  2  3  4  5  6  7
2  4  6  8  10 12
3  6  9  12 15
4  8  12 16
5  10 15
6  12
7


这是一道让我PE到shi的题,还是我太水微笑

代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<map>
#include<iostream>
#include<vector>
using namespace std;
typedef long long ll;
typedef pair<int,int> P;

int main()
{
    int n,m,t=0;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d",&m);
        int cut=m;
        for(int i=1;i<=m;i++)
        {
            for(int j=1;j<=cut;j++)
            {
                printf("%d",i*j);
                if(i*j>9&&j!=cut)
                    printf(" ");
                else if(i*j<=9&&j!=cut)
                    printf("  ");
            }
            printf("\n");
            cut--;
        }
        if(n)
            printf("\n");
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值