MAC中eclipse安装及tomcat部署等问题及解决方法

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/baidu_37109784/article/details/80316208

按照自己的经验总结一下,有一些比较基础的地方就不说了。

安装及解决问题的大概过程:

        mac中eclipse的版本有好几种,一开始我选了最新的4.7,弄了很久发现没有对应的tomcat插件。目前最新的tomcat插件为v331,它所对应的eclipse版本应该为4.4。折腾了一段时间后,发现搞不定,不过如果想在eclipse4.7版本里装tomcat插件的话,有兴趣的可以尝试一下https://jingyan.baidu.com/article/6fb756ec7a3329241958fb6f.html   这个百度经验。

        eclipse4.7搞不定以后,我就想换回4.4。但是!eclipse4.4直接解压后,发现打不开应用。具体报错:can’t be opened because it is from an unidentified developer.  好像是这个。后面去找解决办法,是因为自己电脑的安全设置级别的原因。参考解决方法:http://osxdaily.com/2012/07/27/app-cant-be-opened-because-it-is-from-an-unidentified-developer/    主旨就是去电脑的偏好设置那里设置一下。

        当处理完上面那个问题后,还是打不开4.4,报错为:Eclipse quit unexpectedly。    这个问题困扰我最久!一开始怎么也找不到原因。导致我在eclipse4.4和4.7两个版本之间换来换去尝试解决。参考解决方法:https://blog.csdn.net/lovelovelovelovelo/article/details/68952465       这个真的绝了,大概就是把app那个图标拖出到桌面再拖回去就可以不报这个错误了。不过我并不知道原因,也就这么用了,反正有效。

      后续又有问题,打开之后,具体报错:An Error has Occurred. See the log file  。   这个问题参考解决方法:https://www.jianshu.com/p/be53a74ac5b7    看了这个方法后,想了一下自己的java版本!发现自己用的也是1.9,当时装的时候选了一个最新的。然后按照该方法去卸载java1.9。

        卸载的时候,发现root用户的密码忘记了。参考解决方法:https://www.jianshu.com/p/bea986aeeb8a     可以用当前用户去修改root用户密码。成功删除java1.9后,正常打开eclipse4.4。

        以上遇到elipse打不开和tomcat插件无法生效的问题,最后归结起来都是不同应用间版本的问题。搭环境切记版本之间的兼容性。



顺手传送门一下:

eclipse官网:https://link.jianshu.com/?t=https://www.eclipse.org/downloads/    

tomcat插件:http://www.eclipsetotale.com/tomcatPlugin.html

阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页