The 2015 China Collegiate Programming Contest Sudoku

Sudoku

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 3015    Accepted Submission(s): 1010


Problem Description
Yi Sima was one of the best counselors of Cao Cao. He likes to play a funny game himself. It looks like the modern Sudoku, but smaller.

Actually, Yi Sima was playing it different. First of all, he tried to generate a  4×4 board with every row contains 1 to 4, every column contains 1 to 4. Also he made sure that if we cut the board into four 2×2 pieces, every piece contains 1 to 4.

Then, he removed several numbers from the board and gave it to another guy to recover it. As other counselors are not as smart as Yi Sima, Yi Sima always made sure that the board only has one way to recover.

Actually, you are seeing this because you've passed through to the Three-Kingdom Age. You can recover the board to make Yi Sima happy and be promoted. Go and do it!!!
 

 

Input
The first line of the input gives the number of test cases,  T(1T100)T test cases follow. Each test case starts with an empty line followed by 4 lines. Each line consist of 4 characters. Each character represents the number in the corresponding cell (one of '1', '2', '3', '4'). '*' represents that number was removed by Yi Sima.

It's guaranteed that there will be exactly one way to recover the board.
 

 

Output
For each test case, output one line containing  Case #x:, where  x is the test case number (starting from 1). Then output 4 lines with 4 characters each. indicate the recovered board.
 

 

Sample Input
3 ****
2341
4123
3214
*243
*312
*421
*134
*41*
**3*
2*41
4*2*
 

 

Sample Output
Case #1:
1432
2341
4123
3214
Case #2:
1243
4312
3421
2134
Case #3:
3412
1234
2341
4123
 

 

Source
 

 

Recommend
wange2014
 
 
这个题唯一的问题,可能是需要思考一下i/2,y/2来划分四个格子
#include<bits/stdc++.h>
using namespace std;
#define rap(i,n) for(int i=0;i<n;i++)
#define dap(i,n) for(int i=1;i<=n;i++)
char a[10][10];

int check(int x,int b,char c)
{
    int i;
    rap(i,4)
    {
        if(a[x][i]==c||a[i][b]==c)
        return 1;
    }
    if(x/2==0&&b/2==0)
    {
        if(a[0][0]==c||a[0][1]==c||a[1][0]==c||a[1][1]==c)
        return 1;
    }
    else if(x/2==0&&b/2)
    {
        if(a[0][2]==c||a[0][3]==c||a[1][2]==c||a[1][3]==c)
        return 1;
    }
    else if(x/2&&b/2==0)
    {
        if(a[2][0]==c||a[2][1]==c||a[3][0]==c||a[3][1]==c)
        return 1;
    }
    else if(x/2&&b/2)
    {
        if(a[2][2]==c||a[2][3]==c||a[3][2]==c||a[3][3]==c)
        return 1;
    }
    return 0;
}
void dfs(int x,int y)
{
    int i,j;
    if(x==4)
    {
        for(i=0;i<4;i++)
        {
            for(j=0;j<4;j++)
            printf("%c",a[i][j]);
            printf("\n");
        }
        return;
    }
    if(a[x][y]!='*')
    {
        if(y==3)
        dfs(x+1,0);
        else
        dfs(x,y+1);
    }
    else
    {
        for(i=1;i<=4;i++)
        {
            if(check(x,y,i+'0')==0)
            {
                a[x][y]=i+'0';
                if(y==3)
                dfs(x+1,0);
                else
                dfs(x,y+1);
                a[x][y]='*';
            }
        }

    }
}
int main()
{
    int t,cnt=0;
    cin>>t;
    while(t--)
    {
        rap(i,4)
        scanf("%s",&a[i]);
        cout<<"Case #"<<++cnt<<":"<<endl;
        dfs(0,0);
    }
}

 

 

转载于:https://www.cnblogs.com/upstart/p/8974882.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值