Game FZU - 2275 kmp

Alice and Bob is playing a game.

Each of them has a number. Alice’s number is A, and Bob’s number is B.

Each turn, one player can do one of the following actions on his own number:

1. Flip: Flip the number. Suppose X = 123456 and after flip, X = 654321

2. Divide. X = X/10. Attention all the numbers are integer. For example X=123456 , after this action X become 12345(but not 12345.6). 0/0=0.

Alice and Bob moves in turn, Alice moves first. Alice can only modify A, Bob can only modify B. If A=B after any player’s action, then Alice win. Otherwise the game keep going on!

Alice wants to win the game, but Bob will try his best to stop Alice.

Suppose Alice and Bob are clever enough, now Alice wants to know whether she can win the game in limited step or the game will never end.

Input

First line contains an integer T (1 ≤ T ≤ 10), represents there are T test cases.

For each test case: Two number A and B. 0<=A,B<=10^100000.

Output

For each test case, if Alice can win the game, output “Alice”. Otherwise output “Bob”.

Sample Input

4
11111 1
1 11111
12345 54321
123 123

Sample Output

Alice
Bob
Alice
Alice

Hint

For the third sample, Alice flip his number and win the game.

For the last sample, A=B, so Alice win the game immediately even nobody take a move.

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<utility>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<stack>
#define maxn 100010
#define INF 0x3f3f3f3f
#define LL long long
#define ULL unsigned long long
#define E 1e-8
#define mod 1000000007
#define P pair<int,int>
using namespace std;

int t,n,m;
char a[maxn],b[maxn],c[maxn];
int Next[maxn];
void makeNext()
{
    int q=0,k=-1;
    Next[0]=-1;
    while(q<m){
        if(k==-1||b[q]==b[k]) Next[++q]=++k;
        else k=Next[k];
    }
}
int kmp()
{
    int i=0,q=0;
    makeNext();
    while(i<n&&q<m){
        if(q==-1||a[i]==b[q]){
            i++;
            q++;
        }
        else q=Next[q];
    }
    if(q==m) return i-m+1;
    else return -1;
}


int main()
{
    scanf("%d",&t);
    while(t--){
        cin>>a>>b;
        n=strlen(a);
        m=strlen(b);
        if(m==1&&b[0]=='0'){
            printf("Alice\n");
        }
        else if(n<m){
            printf("Bob\n");
        }
        else{
            if(kmp()!=-1){
                printf("Alice\n");
            }
            else{
                for(int i=0;i<m;i++){
                    c[m-i-1]=b[i];
                }
                for(int i=0;i<m;i++){
                    b[i]=c[i];
                }
                if(kmp()!=-1){
                    printf("Alice\n");
                }
                else printf("Bob\n");
            }
        }
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/upstart/p/8982319.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值