OJ-2021/10/22

这篇博客包含两个C语言程序,分别用于计算两个整数之和(A+B Problem)和1到n的整数之和(Sum Problem)。程序通过输入整数,运用循环结构进行求和运算,并输出结果。这两个简单的程序展示了基础的C语言编程技巧和数学计算方法。
摘要由CSDN通过智能技术生成

1000.A + B Problem

Problem Description

Calculate A + B.

Input

Each line will contain two integers A and B.Process to end of file.

Output

For each case,output A+B in one line.

Sample Input

1 1

Sample Output

2

#include <stdio.h>

int main(){
    int a,b;
    while(scanf("%d %d",&a,&b)!=EOF){
         printf("%d\n",a+b);
      }
      return 0;
}

1001.Sum Problem

Problem Description

Hey,welcome to HDUOJ(Hangzhou Dianzi University Online Judge).

In this problem,your task is to calculate SUM(n) = 1+2+3+...+n,

Input

The input will consist of a series of integers n,one integer per line.

Output 

For each case,output SUM(n) in one line,followed by a blank line.You may assume the result will be in the range of 32-bit signed integer.

Sample Input

1

100

Sample Output

1

5050

#define _CRT_SECURE_NO_WARNINGS

#include <stdio.h>


int main() {

	int n, sum = 0;
	while(scanf("%d", &n) != EOF) {
		for (int i = n; i >= 1; i--) {
			sum += i;
		}
		printf("%d\n", sum);
		printf("\n");
		sum = 0;
		
	}

	return 0; 
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值