hdu 2196 Computer

Computer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 37614    Accepted Submission(s): 6579
Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information. 


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 
Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 
Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 
Sample Input
5 1 1 2 1 3 1 1 1
 
Sample Output
3 2 3 4 4

    题意:有n台电脑,有(n-1)条边连接,每条边有权值,问每台电脑距离其他电脑的最远距离是多少。

 

   题解:树形DP。要求一个点到其他点的最远距离的话,得出此点最大距离 = max ( max (此点子树方向的最大距离) , max (此点父亲方向的最大距离) ),此点子树方向的最大距离深搜即可求得,下面开始求此点父亲方向的最大距离。

     令dp[i][0]表示为节点i子树方向的最大距离,dp[i][1]表示为节点i子树方向的次大距离dp[i][2]表示为i节点父亲方向的最大距离,s表示为子节点,f表示为父节点,w表示为子父节点的距离

     那么存在两种情况:

   ① s在f子树方向的最大距离路径上。                                                                                                                                                      

 

 

     dp[s][2]=max(dp[f][1],dp[f][2])+w; 

 

 

     

 

 

   ② s在f子树方向的最大距离路径上。 

   

 

     dp[s][2]=max(dp[f][0],dp[f][2])+w; 

   

     

 

 

   代码:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn=10005;
struct node
{
  int v,w;
  node(){}
  node(int a,int b)
   {v=a;w=b;}
};
vector<node> e[maxn];
int n,dp[maxn][3];
void dfs1(int s,int fa);
void dfs2(int s,int fa);
int main()
{
   int i,j,a,b;
   while(~scanf("%d",&n))
   {
      for(i=0;i<maxn;i++) e[i].clear();
      fill(dp[0],dp[0]+maxn*3,0);
      for(i=2;i<=n;i++)
      {
        scanf("%d%d",&a,&b);
        e[i].push_back(node(a,b));
        e[a].push_back(node(i,b));
      }
      dfs1(1,-1);
      dfs2(1,-1);
      for(i=1;i<=n;i++) printf("%d\n",max(dp[i][0],dp[i][2]));
   }
  system("pause");
  return 0;
}
void dfs1(int s,int fa)  //子树方向的最大距离和次大距离
{
  int i,v,w;
  for(i=0;i<e[s].size();i++)
   {
     v=e[s][i].v;
     if(v==fa) continue;
     dfs1(v,s);
     w=dp[v][0]+e[s][i].w;
     if(w>=dp[s][0])
      {
        dp[s][1]=dp[s][0];
        dp[s][0]=w;
      }
     else if(w>dp[s][1]) dp[s][1]=w;
   }
}
void dfs2(int s,int fa)  //父亲方向的最大距离
{
  int i,v,w;
  for(i=0;i<e[s].size();i++)
  {
    v=e[s][i].v;w=e[s][i].w;
    if(v==fa) continue;
    if(dp[s][0]==dp[v][0]+w) dp[v][2]=max(dp[s][1],dp[s][2])+w;
    else dp[v][2]=max(dp[s][0],dp[s][2])+w;
    dfs2(v,s);
  }
}

 

转载于:https://www.cnblogs.com/VividBinGo/p/11287951.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值