poj 1787 Charlie's Change

Charlie's Change

Time Limit: 1000MS   Memory Limit: 30000K

Total Submissions: 5731   Accepted: 1849

Description

Charlie is a driver of Advanced Cargo Movement, Ltd. Charlie drives a lot and so he often buys coffee at coffee vending machines at motorests. Charlie hates change. That is basically the setup of your next task. 
Your program will be given numbers and types of coins Charlie has and the coffee price. The coffee vending machines accept coins of values 1, 5, 10, and 25 cents. The program should output which coins Charlie has to use paying the coffee so that he uses as many coins as possible. Because Charlie really does not want any change back he wants to pay the price exactly. 

Input

Each line of the input contains five integer numbers separated by a single space describing one situation to solve. The first integer on the line P, 1 <= P <= 10 000, is the coffee price in cents. Next four integers, C1, C2, C3, C4, 0 <= Ci <= 10 000, are the numbers of cents, nickels (5 cents), dimes (10 cents), and quarters (25 cents) in Charlie's valet. The last line of the input contains five zeros and no output should be generated for it.

Output

For each situation, your program should output one line containing the string "Throw in T1 cents, T2 nickels, T3 dimes, and T4 quarters.", where T1, T2, T3, T4 are the numbers of coins of appropriate values Charlie should use to pay the coffee while using as many coins as possible. In the case Charlie does not possess enough change to pay the price of the coffee exactly, your program should output "Charlie cannot buy coffee.".

Sample Input

12 5 3 1 2 16 0 0 0 1 0 0 0 0 0 

Sample Output

Throw in 2 cents, 2 nickels, 0 dimes, and 0 quarters. 
Charlie cannot buy coffee.

题意:有1,5,10,25元硬币各C1, C2, C3, C4个,求正好可以买一杯价值P元的咖啡需要的最多的硬币数,输出每种硬币个数。

题解:完全背包+记录路径。

代码:
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
const int maxn=10005,inf=0x3f3f3f3f;
int num[5],cnt[maxn],w[5]={0,1,5,10,25},dp[maxn],path[maxn],ans[30];
int main()
{
  int i,j,P;
  while(scanf("%d%d%d%d%d",&P,&num[1],&num[2],&num[3],&num[4]))
  {
   if(P+num[1]+num[2]+num[3]+num[4]==0) break;
   {
     fill(dp,dp+maxn,-inf);
     fill(path,path+maxn,-1);
     fill(ans,ans+30,0);
     dp[0]=0;
   }
   for(i=1;i<=4;i++)
   {
    fill(cnt,cnt+maxn,0);
    for(j=w[i];j<=P;j++)
     if(dp[j-w[i]]+1>dp[j]&&cnt[j-w[i]]+1<=num[i])
     {
      dp[j]=dp[j-w[i]]+1;
      cnt[j]=cnt[j-w[i]]+1;
      path[j]=w[i];
     }
   }
   if(dp[P]<0)  printf("Charlie cannot buy coffee.\n");
   else
   {
     i=P;
     while(i>0)
       ans[path[i]]++,i-=path[i];
     printf("Throw in %d cents, %d nickels, %d dimes, and %d quarters.\n",ans[1],ans[5],ans[10],ans[25]);
   }
  }
  return 0;
}

转载于:https://www.cnblogs.com/VividBinGo/p/11366841.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值