HDU 1501 Zipper 【DFS+剪枝】

HDU 1501 Zipper 【DFS+剪枝】

Problem Description
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming “tcraete” from “cat” and “tree”:

String A: cat
String B: tree
String C: tcraete

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming “catrtee” from “cat” and “tree”:

String A: cat
String B: tree
String C: catrtee

Finally, notice that it is impossible to form “cttaree” from “cat” and “tree”.

Input
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

Output
For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output

Data set 1: yes
Data set 2: yes
Data set 3: no

题意
给出三串字符串 a, b, c 判断 字符串C 中的每个字符 是不是分别从a, b 字符串中 顺序取出的。也就是说 从c字符串中 按顺序 能不能取出 a ,b 字符串 可以不连续 但顺序不能变

思路
如果给出样例满足题意,那么必然满足字符串C 的最后一位肯定是 字符串A或者字符串B的最后一位 ,然后再往前找,那么从前往后找也是一样的。就可以用DFS去搜,但是需要剪枝。不然TLE

AC代码

#include <bits/stdc++.h>         //DFS+剪枝 
using namespace std;
const int maxn = 2 * 1e2 + 5;
string a, b, c;
int len_a, len_b, len_c;
int ans;
int vis[maxn][maxn];
void dfs(int x, int y)
{
    if (x + y == len_c)
    {
        ans = 1;
        return ;
    }   
    if (vis[x][y])       //剪枝
        return ;
    if (a[x] == c[x + y])
    {
        vis[x][y] = 1;
        dfs(x + 1, y);
    }   
    if (b[y] == c[x + y])
    {
        vis[x][y] = 1;
        dfs(x, y + 1);
    }   
}
int main()
{
    int t;
    int k;
    cin >> t;
    for (k = 1; k <= t; k++)
    {
        cin >> a >> b >> c;
        len_a = a.size(), len_b = b.size(), len_c = c.size();
        printf("Data set %d: ", k);
        ans = 0;
        memset(vis, 0, sizeof(vis));
        dfs(0, 0);
        if (ans)
            cout << "yes\n";
        else
            cout << "no\n";
    }
}

转载于:https://www.cnblogs.com/Dup4/p/9433397.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值