Description
We give the following inductive definition of a “regular brackets” sequence:
- the empty sequence is a regular brackets sequence,
- if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
- if a and b are regular brackets sequences, then ab is a regular brackets sequence.
- no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:
(), [], (()), ()[], ()[()]
while the following character sequences are not:
(, ], )(, ([)], ([(]
Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.
Given the initial sequence ([([]])]
, the longest regular brackets subsequence is [([])]
.
Input
The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (
, )
, [
, and ]
; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.
Output
For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.
Sample Input
((())) ()()() ([]]) )[)( ([][][) end
Sample Output
6 6 4 0 6
题意:类似于最长公共子序列的最大匹配括号数
思路:明显就是一种自底向上型DP,
// 求最长合法子序列
// 区间 dp
// dp[i][j] 表示区间 i,j 的最长合法子序列
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
int dp[105][105];
bool cmp(char c1, char c2)
{
if(c1 == '(' && c2 == ')')
return true;
if(c1 == '[' && c2 == ']')
return true;
return false;
}
int main()
{
strings;
while(cin>>s && s != "end")
{
int length = s.length();
for(int i = 0 ; i < length; i++)
{
dp[i][i] = 0;
if(cmp(s[i],s[i+1]))
{
dp[i][i+1] = 2;
}
else
dp[i][i+1] = 0;
}
for(int k=3;k<=length;k++)
{
for(int i=0;i+k-1<length;i++)
{
dp[i][i+k-1]=0;
if(cmp(s[i],s[i+k-1]))
{
dp[i][i+k-1]=dp[i+1][i+k-2]+2;
}
for(int j=i;j<i+k-1;j++)
{
dp[i][i+k-1]=max(dp[i][i+k-1],dp[i][j]+dp[j+1][i+k-1]);
}
}
}
cout<<dp[0][length-1]<<endl;
}
return 0;
}