【C++ 函数模板】SDUT-1141 面向对象程序设计上机练习二(函数模板)

9 篇文章 0 订阅

Problem Description

利用数组和函数模板求5个数最大值(分别考虑整数、单精度、长整数的情况)。

Input

分别输入5个int型整数、5个float 型实数、5个long型正整数。

Output

分别输出5个int型整数的最大值、5个float 型实数的最大值、5个long型正整数的最大值。

Example Input

11 22 666 44 55
11.11 22.22 33.33 888.88 55.55
1234567 222222 333333 444444 555555

Example Output

666
888.88
1234567

使用函数模板目的:

程序员只需对函数模板编写一次,然后基于调用函数时提供的参数类型,C++编译器将自动产生相应的函数来正确地处理该类型的数据。

#include <iostream>
using namespace std;
template <typename T>//重点
T findmax(T a[])
{
    T Max = 0;
    for(int i = 0; i < 5; i++)
    {
        if(Max < a[i])
            Max = a[i];
    }
    return Max;

}
int main()
{
    int a[10];
    float b[10];
    long c[10];
    for(int i = 0; i < 5; i++)
        cin >> a[i];
    cout << findmax(a) << endl;
    for(int i = 0; i < 5; i++)
        cin >> b[i];
    cout << findmax(b) << endl;
    for(int i = 0; i < 5; i++)
        cin >> c[i];
    cout << findmax(c) << endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值