Number Sequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 158167 Accepted Submission(s): 38744
Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3 1 2 10 0 0 0
Sample Output
2 5
Author
CHEN, Shunbao
Source
Recommend
JGShining
规律是48个一个循环,直接打表前48个,再取余一下就好了。
#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
#define mod 7
using namespace std;
typedef long long LL;
const int N = 100;
int ans[N];
void init(int A,int B){
ans[1]=1,ans[2]=1;
for(int i=3;i<=48;i++){
ans[i]=(A*ans[i-1]%mod+B*ans[i-2]%7)%7;
}
}
int main(){
LL A,B,n;
while(scanf("%lld%lld%lld",&A,&B,&n),A||B||n){
init(A,B);
printf("%d\n",ans[n%48]);
}
return 0;
}