数据结构上机测试2-1:单链表操作A

数据结构上机测试2-1:单链表操作A
Time Limit: 1000 ms Memory Limit: 4096 KiB
Submit Statistic Discuss
Problem Description

输入n个整数,先按照数据输入的顺序建立一个带头结点的单链表,再输入一个数据m,将单链表中的值为m的结点全部删除。分别输出建立的初始单链表和完成删除后的单链表。
Input

第一行输入数据个数n;
第二行依次输入n个整数;
第三行输入欲删除数据m。
Output

第一行输出原始单链表的长度;
第二行依次输出原始单链表的数据;
第三行输出完成删除后的单链表长度;
第四行依次输出完成删除后的单链表数据。
Sample Input

10
56 25 12 33 66 54 7 12 33 12
12
Sample Output

10
56 25 12 33 66 54 7 12 33 12
7
56 25 33 66 54 7 33
Hint

Source

#include<stdio.h>
#include<stdlib.h>
int n;
struct node
{
    int data;
    struct node*next;
};
struct node* create(int n)
{
    struct node*head,*p,*tail;
    head=(struct node*)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;
    int i;
    for(i=1;i<=n;i++)
    {
        p=(struct node*)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=NULL;
        tail->next=p;
        tail=p;
    }
    return head;
}
void dele(struct node*head,int num)
{
    struct node*p;
    p=head;
    while(p->next)
    {
        if(p->next->data==num)
        {
            p->next=p->next->next;
            n--;
        }
        else p=p->next;
    }
}//比较的是p->next;
void print(struct node*head)
{
    struct node*p;
    p=head->next;
    while(p)
    {
        if(p==head->next)
        {
            printf("%d",p->data);
        }
        else printf(" %d",p->data);
        p=p->next;
    }
    printf("\n");
}
int main()
{   int num;
    struct node*h;
    scanf("%d",&n);
    h=create(n);
    scanf("%d",&num);
    printf("%d\n",n);
    print(h);
    dele(h,num);
    printf("%d\n",n);
    print(h);
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值