hdu 5532 Almost Sorted Array

Almost Sorted Array

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 270    Accepted Submission(s): 130


Problem Description
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array  a1,a2,,an , is it almost sorted?
 

Input
The first line contains an integer  T  indicating the total number of test cases. Each test case starts with an integer  n  in one line, then one line with  n  integers  a1,a2,,an .

1T2000
2n105
1ai105
There are at most 20 test cases with  n>1000 .
 

Output
For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
  
  
3 3 2 1 7 3 3 2 1 5 3 1 4 1 5
 

Sample Output
  
  
YES YES NO
 
题目大意:
       判断一个数列去掉一个数之后是不是不下降或者不上升数列。
解题思路:
        假设它是不下降从前往后找断点,在从后往前找断点,再假设它是不上升做类似处理;
最后有这几种情况:
1.无断点,即它本身就是不下降或者不上升序列,那么只要去掉头或者尾就好;
2.断点在头尾,即除了头尾剩下的数列满足,也是只要去掉头尾就好;
3.断点在中间,判断断点前一位和断点后一位是否满足要求;
本质就是模拟;

代码:
#include "iostream"
#include "cstdio"
#include "string.h"
#include "math.h"
using namespace std;

int a[110000],n,x[110000],y[110000];
bool ins()
{
    x[1]=1;
    for(int i=2;i<=n;i++)
    {
        if(a[i]>=a[i-1])
            x[i]=x[i-1]+1;
        else
            x[i]=1;
    }
    y[n]=1;
    for(int i=n-1;i>0;i--)
    {
        if(a[i]<=a[i+1])
            y[i]=y[i+1]+1;
        else
            y[i]=1;
    }
    for(int i=2;i<n;i++)
    {
        if(a[i-1]<=a[i+1]&&x[i-1]+y[i+1]>=n-1)
            return true;
    }
    if(x[n-1]==n-1||y[2]==n-1||x[n]==n)
        return true;
    return false;
}

bool de()
{
    x[1]=1;
    for(int i=2;i<=n;i++)
    {
        if(a[i]<=a[i-1])
            x[i]=x[i-1]+1;
        else
            x[i]=1;
    }
    y[n]=1;
    for(int i=n-1;i>0;i--)
    {
        if(a[i]>=a[i+1])
            y[i]=y[i+1]+1;
        else
            y[i]=1;
    }
    for(int i=2;i<n;i++)
    {
        if(a[i-1]>=a[i+1]&&x[i-1]+y[i+1]>=n-1)
            return true;
    }
    if(x[n-1]==n-1||y[2]==n-1||x[n]==n)
        return true;
    return false;
}

int main()
{
    int T;
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d", &n);
        for (int i = 1; i <=n; i++)
            scanf("%d", &a[i]);
        if (ins() || de())
            puts("YES");
        else
            puts("NO");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值