The Center of Gravity

The Center of Gravity
Problem Description
Everyone know the story that how Newton discovered the Universal Gravitation. One day, Newton walked
leisurely, suddenly, an apple hit his head. Then Newton discovered the Universal Gravitation.From then
on,people have sovled many problems by the the theory of the Universal Gravitation. What’s more, wo also
have known every object has its Center of Gravity.
Now,you have been given the coordinates of three points of a triangle. Can you calculate the center
of gravity of the triangle?
Input
The first line is an integer n,which is the number of test cases.
Then n lines follow. Each line has 6 numbers x1,y1,x2,y2,x3,y3,which are the coordinates of three points.
The input is terminated by n = 0.
Output
For each case, print the coordinate, accurate up to 1 decimal places.
Sample Input
2
1.0 2.0 3.0 4.0 5.0 2.0
1.0 1.0 4.0 1.0 1.0 5.0
0
Sample Output
3.0 2.7
2.0 2.3
问题描述
每个人都知道牛顿是如何发现万有引力的。一天,牛顿走了
悠闲地,突然,一个苹果击中了他的头部。然后牛顿发现了万有引力。
人们用万有引力理论解决了许多问题。更重要的是,我们也
知道每一个物体都有它的重心。
现在,你得到了三角形的三个点的坐标。你能计算出这个中心吗?
三角形的引力?
输入
第一行是整数n,它是测试用例的数量。
然后N行跟着。每条线有6个数字x1,y1,x2,y2,x3,y3,它们是三个点的坐标。
输入由n=0终止。
产量
对于每种情况,打印坐标,精确到1个小数点。
样本输入
2
1 2 3 3 4 5 2
1 1 4 4 1 1 5
0
样本输出
3 2.7
2 2.3
方法:求三角形重心
一个三角形三点坐标为:(x1,y1)(x2,y2)(x3,y3)
重心坐标为:((x1+x2+x3)/3,(y1+y2+y3)/3).
上代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    double x1,y1,x2,y2,x3,y3,ax,ay;
    while(cin>>n)
    {
        if(n==0)
            return 0;
        for(int i=1;i<=n;++i)
        {
            cin>>x1>>y1>>x2>>y2>>x3>>y3;
            ax=(x1+x2+x3)/3;
            ay=(y1+y2+y3)/3;
            printf("%0.1f %0.1f\n",ax,ay);
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值