PAT 1015. Reversible Primes (20)

A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

思路:题目的意思是把数N按D进制表示,然后把所以位颠倒,再转化为10进制的数。注意原来的数也要先判断是否为素数,转化后数如果也为素数的话,输出Yes,反之,输出No

#include <iostream>
#include <algorithm>
#include <string>

using namespace std;

bool isprime(int a) //判断一个数是否为素数
{
    if (a < 2)
       return false;
    if (a==2 || a==3)
       return true;
    for (int i=2; i*i<=a; ++i)
        if (a % i == 0)
            return false;
    return true;
}

int main()
{
    int a, index;
    while (cin >> a && a>=0) {
        string s;
        cin >> index; //进制位
      if (isprime(a)) {  
        do {           //把数字直接拆位反转
            s += (a%index + '0');
            a /= index;
        }while (a);

        if ( isprime(stoi( s.c_str(), 0 ,index ) ) ) //利用stoi把字符串转化为10进制,c++11才支持此函数
            cout << "Yes" << endl;
        else
            cout << "No" << endl;
    }
    else
     cout << "No" << endl;
    }
   // system("pause");
    return 0;
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值