PAT 1023. Have Fun with Numbers (20)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798

思路:把数字翻倍,如果结果里面的数字都是原数字的另外排列,输出Yes,由于数据比较大,我们用字符串去做这件事。 

#include<iostream>
#include<string>

using namespace std;

int main()
{
   string s, st;
   cin >> s;
   int c = 0, t;
   for (int i=s.size()-1; i>=0; --i) {  //拆分字符串每一数字进行双倍运算
	   t = c+(s[i] - '0') * 2;
	   st.insert(st.begin(),  t%10 +'0');
	   c = t / 10;
   }
   if (c) //最高位有进位
	   st.insert(st.begin(), c+'0');
   if (s.find_first_not_of(st) == -1 && s.size() == st.size())
	   cout << "Yes" << endl; //原字符串与翻倍字符串里面数字字符相同,排列不同
   else 
	   cout << "No" << endl;
   cout << st << endl;
   system("pause");

   return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值