HDU 3709 数位dp

Balanced Number

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)


Problem Description
A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job
to calculate the number of balanced numbers in a given range [x, y].
 

Input
The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 10 18).
 

Output
For each case, print the number of balanced numbers in the range [x, y] in a line.
 

Sample Input
  
  
2 0 9 7604 24324
 
Sample Output
  
  
10 897


题意:给你一个区间,求区间内所有平衡数。

平衡数是指可以找到一个支点,左边右边的数乘以力矩加起来之和相等。


题解:数位dp,但要注意排除00,000,这样的情况。


#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef long long ll;
ll dp[20][20][2000];
ll digit[20];
ll dfs(ll len,ll fixloc,ll sum,bool fp){
	if(!len){
		return sum==0?1:0;
	}
	if(sum<0)return 0;
	if(!fp&&dp[len][fixloc][sum]!=-1)return dp[len][fixloc][sum];
	ll ret=0,i,fpmax=fp?digit[len]:9;
	for(i=0;i<=fpmax;i++){
		ret+=dfs(len-1,fixloc,sum+i*(len-fixloc),fp&&i==fpmax);
	}
	if(!fp)dp[len][fixloc][sum]=ret;
	return ret;
}
ll solve(ll n){
	if(n==-1)return 0;
	if(n==0)return 1;
	ll len=0;
	while(n){
		digit[++len]=n%10;
		n/=10;
	}
	ll ret=0,i;
	for(i=len;i>=1;i--){
		ret+=dfs(len,i,0,true);
	}
	return ret-len+1;//排除00,000这些情况
}
int main(){
	memset(dp,-1,sizeof(dp));
	ll t,x,y;
	scanf("%lld",&t);
	while(t--){
		scanf("%lld%lld",&x,&y);
		printf("%lld\n",solve(y)-solve(x-1));
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值