ZOJ 3962 想法

Seven Segment Display

Time Limit: 2 Seconds       Memory Limit: 65536 KB

A seven segment display, or seven segment indicator, is a form of electronic display device for displaying decimal numerals that is an alternative to the more complex dot matrix displays. Seven segment displays are widely used in digital clocks, electronic meters, basic calculators, and other electronic devices that display numerical information.

Edward, a student in Marjar University, is studying the course "Logic and Computer Design Fundamentals" this semester. He bought an eight-digit seven segment display component to make a hexadecimal counter for his course project.

In order to display a hexadecimal number, the seven segment display component needs to consume some electrical energy. The total energy cost for display a hexadecimal number on the component is the sum of the energy cost for displaying each digit of the number. Edward found the following table on the Internet, which describes the energy cost for display each kind of digit.

DigitEnergy Cost
(units/s)
06
12
25
35
44
55
66
73
DigitEnergy Cost
(units/s)
87
96
A6
B5
C4
D5
E5
F4

For example, in order to display the hexadecimal number "5A8BEF67" on the component for one second, 5 + 6 + 7 + 5 + 5 + 4 + 6 + 3 = 41 units of energy will be consumed.

Edward's hexadecimal counter works as follows:

  • The counter will only work for n seconds. After n seconds the counter will stop displaying.
  • At the beginning of the 1st second, the counter will begin to display a previously configured eight-digit hexadecimal number m.
  • At the end of the i-th second (1 ≤ i < n), the number displayed will be increased by 1. If the number displayed will be larger than the hexadecimal number "FFFFFFFF" after increasing, the counter will set the number to 0 and continue displaying.

Given n and m, Edward is interested in the total units of energy consumed by the seven segment display component. Can you help him by working out this problem?

Input

There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 105), indicating the number of test cases. For each test case:

The first and only line contains an integer n (1 ≤ n ≤ 109) and a capitalized eight-digit hexadecimal number m (00000000 ≤ m ≤ FFFFFFFF), their meanings are described above.

We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each test case output one line, indicating the total units of energy consumed by the eight-digit seven segment display component.

Sample Input
3
5 89ABCDEF
3 FFFFFFFF
7 00000000
Sample Output
208
124
327
Hint

For the first test case, the counter will display 5 hexadecimal numbers (89ABCDEF, 89ABCDF0, 89ABCDF1, 89ABCDF2, 89ABCDF3) in 5 seconds. The total units of energy cost is (7 + 6 + 6 + 5 + 4 + 5 + 5 + 4) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 6) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 2) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 5) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 5) = 208.

For the second test case, the counter will display 3 hexadecimal numbers (FFFFFFFF, 00000000, 00000001) in 3 seconds. The total units of energy cost is (4 + 4 + 4 + 4 + 4 + 4 + 4 + 4) + (6 + 6 + 6 + 6 + 6 + 6 + 6 + 6) + (6 + 6 + 6 + 6 + 6 + 6 + 6 + 2) = 124.


题意:给你十六进制下  每个数字的价值  问从m开始  显示n个十六进制数字需要的价值  定义FFFFFFFF+1=0


题解:直接暴力算  算出最大位在哪  

然后对于当前位  for a[i]-1->0  然后在这个位子后面的数是随便取的  也就是 16^(i-1) 种不同的情况

数字的价值就是  16^(i-1)/16*(i-1)*sum[15]

再算出来当前位的价值  val*16^(i-1) 和前面的价值  now*16^(i-1)

把当前位的价值加到now里面  

这样保证不会重复算


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
ll num[20]={6,2,5,5,4,5,6,3,7,6,6,5,4,5,5,4},pow[10],sum[20];
void init(){
    pow[0]=1;
    for(ll i=1;i<=8;i++)pow[i]=pow[i-1]*16;
    sum[0]=6;
    for(ll i=1;i<=15;i++)sum[i]=sum[i-1]+num[i];
}
ll solve(ll t){
    if(t==-1)return 0;
    if(t==0)return 48;
    ll a[10]={0,0,0,0,0,0,0,0,0,0};
    ll x=t,cnt=0;
    while(x>=16){
        a[++cnt]=x%16;
        x/=16;
    }
    if(x>0)a[++cnt]=x;
    ll i,j,ans=0,now=0;
    for(i=8;i>cnt;i--){
    	now+=6;
    }
    for(i=cnt;i>=2;i--){
    	for(j=a[i]-1;j>=0;j--){
	    	ans+=pow[i-2]*(i-1)*sum[15]+pow[i-1]*num[j];
	    	ans+=pow[i-1]*now;
	    }
	    now+=num[a[i]];
    }
    for(j=a[1];j>=0;j--)ans+=now+num[j];
    return ans;
}
int main(){
    int t;
    scanf("%d",&t);
    init();
    while(t--){
        ll n,m;
        scanf("%lld%llx",&n,&m);
        ll ans;
        if(m+n-1>4294967295LL)printf("%lld\n",solve(4294967295LL)-solve(m-1)+solve((m+n-1)%4294967296LL));
        else printf("%lld\n",solve(m+n-1)-solve(m-1));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值