Labeling Balls--拓扑排序

Labeling Balls
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13411 Accepted: 3871

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

题目链接:http://poj.org/problem?id=3687


坑啊坑,poj的后台数据神坑啊,我找了好几个题解才找到我哪错了。

题目的大体意思是给你n个质量从1~n的球,让你给他编号,条件满足

  1. 任何两个球的编号都不一样
  2. 编号满足一些约束,类似于“编号a的球比编号为b的球轻

然后给出m个约束条件。让你输出编号1-n的球的重量。

知道是个拓扑排序的题,上来正向建的图,结果题目要满足如果有多种选择则让重量小的对应编号1,然后就卡死了,上网上看了一下题解,不得不说,大神就是多啊,反向建图,又学了一招。

其实一开始很尴尬,因为读不懂题,所幸网上有个例子

比如给出例子:

1

5 4

1 4

4 2

5 3

3 2

先得到编号的序列2 4 3 5 1,再与5 4 3 2 1一一对应,得到ans[2] = 5, ans[4] = 4, ans[3] = 3, ans[5] = 2, ans[1] = 1

从而找到输出答案1 5 3 4 2。

这样就很好懂了吧,至于拓扑排序这里就不讲了。


代码(大神路过求指教):

#include <cstdio>
#include <cstring>
#include <iostream>
#include <queue>
using namespace std;
int a[500][500];
int b[500];
int ans[500];
int nn;
int top_sort(int n)
{
    priority_queue<int ,vector<int >,less<int > >q;
    //priority_queue<int >q;//今天才知道原来刚建出来的优先队列是非递增的
    while(!q.empty())
        q.pop();
    int i;
    for(i=1; i<=n; i++)
    {
        if(ans[i]==0)
        {
            q.push(i);
        }
    }
    for(i=1; i<=n; i++)
    {
        if(q.size()==0)
            return 0;
        else
        {
            int k=q.top();
            q.pop();
            b[k]=nn--;
            for(int j=1; j<=n; j++)
            {
                if(a[k][j]==1&&!(--ans[j]))//交了好几次wa是因为我写成了!(ans[j]--)
                    q.push(j);
            }
        }
    }
    return 1;
}
int main()
{
    int t;
    int n,m;
    int x,y;
    int i;
    scanf("%d",&t);
    while(t--)
    {
        memset(a,0,sizeof(a));
        memset(ans,0,sizeof(ans));
        scanf("%d%d",&n,&m);
        nn=n;
        for(i=0; i<m; i++)
        {
            scanf("%d%d",&y,&x);
            if(a[x][y]==0)//注意坑点!!,没有这个if你就会while(1) printf("wa\n");
                ans[y]++;
            a[x][y]=1;
        }
        int k=top_sort(n);
        if(k)
        {
            for(i=1;i<=n;i++)
            {
                printf(i==1?"%d":" %d",b[i]);
            }
            cout<<endl;
        }
        else
            cout<<"-1"<<endl;
    }
    return 0;
}

     代码之路漫漫啊。。。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值