nyoj 1242 Interference Signal(暴力枚举)

60 篇文章 1 订阅
15 篇文章 0 订阅

描述
Dr.Kong’s laboratory monitor some interference signals. The interference signals can be digitized into a series of positive integer. May be, there are N integers a1,a2,…,an.

Dr.Kong wants to know the average strength of a contiguous interference signal block. the block must contain at least M integers.

Please help Dr.Kong to calculate the maximum average strength, given the constraint.

输入
The input contains K test cases. Each test case specifies:
* Line 1: Two space-separated integers, N and M.
* Lines2~line N+1: ai (i=1,2,…,N)
1 ≤ K≤ 8, 5 ≤ N≤ 2000, 1 ≤ M ≤ N, 0 ≤ ai ≤9999
输出
For each test case generate a single line containing a single integer that is 1000 times the maximal average value. Do not perform rounding.
样例输入
2
10 6
6
4
2
10
3
8
5
9
4
1
5 2
10
3
8
5
9
样例输出
6500
7333
来源
第八届河南省程序设计大赛

ps:被水题卡了好久,,忽然灵光一现,直接枚举选多少个就好了。。。

代码:

#include<stdio.h>

#define Max(a,b) (a>b?a:b)
#define maxn 2010
int a[maxn];

int main()
{
    int t,n,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; ++i)
            scanf("%d",&a[i]);
        double maxx=0.0;
        for(int i=m; i<=n; ++i)
        {
            double tmp=0;
            int k=0;
            for(int j=1; j<=n; ++j)
            {
                tmp+=a[j];
                ++k;
                if(k==i)
                {
                    double tot=tmp*1.0/i;
                    maxx=Max(tot,maxx);
                    tmp=tmp-a[j-k+1];
                    --k;
                }
            }
        }
        printf("%d\n",(int)(maxx*1000));
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值