2017ccpc全国邀请赛(湖南湘潭) E. Partial Sum(前缀和)

115 篇文章 0 订阅

Partial Sum

Bobo has a integer sequence a1,a2,…,an of length n. Each time, he selects two ends 0≤l<r≤n and add |∑rj=l+1aj|−C into a counter which is zero initially. He repeats the selection for at most m times.

If each end can be selected at most once (either as left or right), find out the maximum sum Bobo may have.

Input

The input contains zero or more test cases and is terminated by end-of-file. For each test case:

The first line contains three integers n, m, C. The second line contains n integers a1,a2,…,an.

2≤n≤105
1≤2m≤n+1
|ai|,C≤104
The sum of n does not exceed 106.
Output

For each test cases, output an integer which denotes the maximum.

Sample Input

4 1 1
-1 2 2 -1
4 2 1
-1 2 2 -1
4 2 2
-1 2 2 -1
4 2 10
-1 2 2 -1
Sample Output

3
4
2
0

官方题解:
这里写图片描述

前缀和排下序,最大前缀和-最小前缀和就是最大的区间和,然后依次枚举就好了

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

typedef long long LL;
const LL maxn=100010;
LL sum[maxn];

int main()
{
    LL n,m,C;
    while(~scanf("%I64d%I64d%I64d",&n,&m,&C))
    {
        LL x;
        sum[0]=0;
        for(LL i=1;i<=n;++i)
        {
            scanf("%I64d",&x);
            sum[i]=sum[i-1]+x;
        }
        sort(sum,sum+n+1);//排序时要从0开始排序(去掉0的话就不能加上从1开始的任意整串)
        LL st=0,ed=n,ans=0;
        while(m--)
        {
            if(sum[ed]-sum[st]-C>0)
                ans+=sum[ed]-sum[st]-C,--ed,++st;
            else
                break;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值